Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1566146 - glibc: [RFE][LLNL 8.n FEAT] Create an option to permanently link in audit library into an executable (glibc)
Summary: glibc: [RFE][LLNL 8.n FEAT] Create an option to permanently link in audit lib...
Keywords:
Status: CLOSED DUPLICATE of bug 1871385
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: glibc
Version: 8.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.2
Assignee: glibc team
QA Contact: qe-baseos-tools-bugs
URL:
Whiteboard:
: 1439350 (view as bug list)
Depends On: 1265827 1439351
Blocks: 1473718 1593423
TreeView+ depends on / blocked
 
Reported: 2018-04-11 15:48 UTC by Nick Clifton
Modified: 2020-12-18 11:24 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1439351
Environment:
Last Closed: 2020-12-18 11:24:55 UTC
Type: Enhancement
Target Upstream Version:


Attachments (Terms of Use)
Tentative upstream patch (5.47 KB, patch)
2019-08-27 14:38 UTC, Florian Weimer
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Sourceware 24943 0 P2 RESOLVED Support DT_AUDIT, DT_DEPAUDIT in the dynamic linker 2020-12-16 14:29:13 UTC

Comment 2 Ben Woodard 2018-11-21 01:20:09 UTC
I think that we should just move this to RHEL8

Comment 3 Carlos O'Donell 2019-06-18 19:04:52 UTC
Ben, Thanks, moving to RHEL8 where we can continue to track toolchain improvements.

Comment 4 Florian Weimer 2019-08-27 14:38:28 UTC
Created attachment 1608655 [details]
Tentative upstream patch

This patch seems to work.  It will require tests before I can submit it upstream.

Comment 5 Florian Weimer 2019-08-28 10:08:24 UTC
*** Bug 1439350 has been marked as a duplicate of this bug. ***

Comment 6 Florian Weimer 2019-08-28 19:25:40 UTC
Comment on attachment 1608655 [details]
Tentative upstream patch

Patch with tests posted upstream: https://sourceware.org/ml/libc-alpha/2019-08/msg00705.html

Comment 7 Florian Weimer 2020-02-24 14:35:00 UTC
We are tracking this upstream already. If/when the feature lands, we will revisit this bug for a decision whether to backport this feature.

Comment 13 Florian Weimer 2020-12-18 11:24:55 UTC
I'm marking this bug as a duplicate of bug 1871385 because that bug is further along in the process.

*** This bug has been marked as a duplicate of bug 1871385 ***


Note You need to log in before you can comment on or make changes to this bug.