Bug 1566194 - [RFE] allow ceph_volume_client to create 'volumes' without namespace isolation
Summary: [RFE] allow ceph_volume_client to create 'volumes' without namespace isolation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: CephFS
Version: 3.0
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: rc
: 3.1
Assignee: Ram Raja
QA Contact: Ramakrishnan Periyasamy
John Brier
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 18:19 UTC by hchen
Modified: 2018-09-26 18:20 UTC (History)
9 users (show)

Fixed In Version: RHEL: ceph-12.2.5-13.el7cp Ubuntu: 12.2.5-4redhat1xenial
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-09-26 18:19:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 24055 0 None None None 2018-05-08 22:50:09 UTC
Red Hat Product Errata RHBA-2018:2819 0 None None None 2018-09-26 18:20:44 UTC

Description hchen 2018-04-11 18:19:47 UTC
Description of problem:

Some kernel cephfs client doesn't support pool namespace. ceph_volume_client should make pool namespace optional for these kernels.

Version-Release number of selected component (if applicable):

RHCS 3.0

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 7 Ramakrishnan Periyasamy 2018-05-09 03:57:25 UTC
Provided QA_ACK

Comment 11 Ram Raja 2018-05-24 09:24:36 UTC
The automated tests for the ceph_volume_client library are here,
https://github.com/ceph/ceph/blob/master/qa/tasks/cephfs/test_volume_client.py
I recommend running the all the tests in the file. You can also run specific tests, test_volume_without_namespace_isolation and test_idempotency

See here,
https://github.com/ceph/ceph/pull/21808/commits/3a7fdb8b052fee2ff1bff24c8de745278314c78c

Comment 17 errata-xmlrpc 2018-09-26 18:19:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2819


Note You need to log in before you can comment on or make changes to this bug.