Bug 1566197 - logspam : CONTAINER_EXITED errors in node logs
Summary: logspam : CONTAINER_EXITED errors in node logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.10.0
Assignee: Seth Jennings
QA Contact: Vikas Laad
URL:
Whiteboard:
Depends On:
Blocks: 1566559
TreeView+ depends on / blocked
 
Reported: 2018-04-11 18:22 UTC by Vikas Laad
Modified: 2018-07-30 19:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1566559 (view as bug list)
Environment:
Last Closed: 2018-07-30 19:12:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:13:33 UTC

Description Vikas Laad 2018-04-11 18:22:23 UTC
Description of problem:
Node logs have lot of these errors, its all the build containers (git clone, sti etc). There is no issue as such, just logs are spammed.

Apr 11 13:17:04 ip-172-31-46-124.us-west-2.compute.internal atomic-openshift-node[7645]: E0411 13:17:04.589338    7645 logs.go:383] Container "4fbf541ed1900c4670216a6a1ecf752cd07ac430f5547c5497fbc4b78e564b78" is not running (state="CONTAINER_EXITED")
Apr 11 14:02:18 ip-172-31-46-124.us-west-2.compute.internal atomic-openshift-node[7645]: E0411 14:02:18.168502    7645 logs.go:383] Container "dba4c535666d05310889965418592727047320743a233e226e2266b399836150" is not running (state="CONTAINER_EXITED")
Apr 11 14:02:41 ip-172-31-46-124.us-west-2.compute.internal atomic-openshift-node[7645]: E0411 14:02:41.342645    7645 logs.go:383] Container "a946289b36fe3c375c29dce020005424f3b980237892253d42b8bd8bfb595756" is not running (state="CONTAINER_EXITED")
Apr 11 14:02:49 ip-172-31-46-124.us-west-2.compute.internal atomic-openshift-node[7645]: E0411 14:02:49.907317    7645 logs.go:383] Container "e1d6014330e7422c03ae6db501d4fb296a4501355517cb60e2f910f54741361d" is not running (state="CONTAINER_EXITED")
Apr 11 14:03:09 ip-172-31-46-124.us-west-2.compute.internal atomic-openshift-node[7645]: E0411 14:03:09.494930    7645 logs.go:383] Container "e9d83032c9e51d1aaa1ba05a5300fc119f3527f94cb3ce7fc521c795e2e58d4d" is not running (state="CONTAINER_EXITED")
Apr 11 14:03:14 ip-172-31-46-124.us-west-2.compute.internal atomic-openshift-node[7645]: E0411 14:03:14.796883    7645 logs.go:383] Container "62ae6a9316b1e86492fb06b9156e652fb2131c88ea242c6efabcfe4b45ec1406" is not running (state="CONTAINER_EXITED")
Apr 11 14:04:09 ip-172-31-46-124.us-west-2.compute.internal atomic-openshift-node[7645]: E0411 14:04:09.201581    7645 logs.go:383] Container "c9217a9af025eb238c1916d5c55bb338ed933b3a8124826d87ad48f100aa2b0c" is not running (state="CONTAINER_EXITED")
Apr 11 14:04:29 ip-172-31-46-124.us-west-2.compute.internal atomic-openshift-node[7645]: E0411 14:04:29.423235    7645 logs.go:383] Container "f2e89bfcc93a3359f071f24c608a94700da6611df627327c86fb4f224bf88d3a" is not running (state="CONTAINER_EXITED")
Apr 11 14:04:38 ip-172-31-46-124.us-west-2.compute.internal atomic-openshift-node[7645]: E0411 14:04:38.311603    7645 logs.go:383] Container "289c7595a39dff41a7f4adfc9af3d673e9601395f306d911c6fc8987bb6765cf" is not running (state="CONTAINER_EXITED")

Version-Release number of selected component (if applicable):
openshift v3.9.19
kubernetes v1.9.1+a0ce1bc657
etcd 3.2.16

How reproducible:
Rub builds 

Steps to Reproduce:
1. oc new-project test
2. oc new-app --template=django-psql-example

Actual results:
Node logs are filled with Errors

Expected results:
These should not be errors since this is normal.

Additional info:

Comment 1 Seth Jennings 2018-04-11 18:23:26 UTC
Kube PR:
https://github.com/kubernetes/kubernetes/pull/62416

Comment 2 Seth Jennings 2018-04-12 14:09:42 UTC
Origin PR:
https://github.com/openshift/origin/pull/19334

Comment 4 Wei Sun 2018-06-04 03:33:56 UTC
Hi Vikas,please check if it could be verified.

Thanks!

Comment 5 Vikas Laad 2018-06-04 19:56:50 UTC
Verified on following version, no errors related to CONTAINER_EXITED found in logs.

openshift v3.9.27

Comment 7 errata-xmlrpc 2018-07-30 19:12:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.