Bug 1566202 - Loading production environment (Rails 4.2.6) Failed to load console gems, starting anyway
Summary: Loading production environment (Rails 4.2.6) Failed to load console gems, sta...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Other
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Peter Ondrejka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 18:41 UTC by Onkar
Modified: 2019-12-03 12:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-03 12:53:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Onkar 2018-04-11 18:41:25 UTC
Description of problem: Run forman-rake console command shows error Loading production environment (Rails 4.2.6)
Failed to load console gems, starting anyway

# foreman-rake console
Loading production environment (Rails 4.2.6)
Failed to load console gems, starting anyway
irb(main):001:0> 

rpm -qa | grep -i satellite
satellite-6.3.0-23.0.el7sat.noarch
rpm -qa | grep -i foreman
foreman-1.15.6.34-1.el7sat.noarch
rpm -qa | grep -i katello
katello-3.4.5-15.el7sat.noarch

Version-Release number of selected component (if applicable):6.3


How reproducible: On satellite 6.3 run foreman-rake console


Steps to Reproduce:
1.
2.
3.

Actual results:# foreman-rake console
Loading production environment (Rails 4.2.6)
Failed to load console gems, starting anyway
irb(main):001:0> 


Expected results:# foreman-rake console

irb(main):001:0> 


Additional info:

Comment 7 Bryan Kearney 2019-11-04 14:34:16 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 8 Bryan Kearney 2019-12-03 12:53:50 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.