Bug 1566252 - [RFE] The requirement is to define and have arbitrary Apache configuration. Options persist and/or reapply during updates.
Summary: [RFE] The requirement is to define and have arbitrary Apache configuration. O...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 20:55 UTC by Onkar
Modified: 2019-01-31 18:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-31 18:31:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Onkar 2018-04-11 20:55:35 UTC
Description of problem:The requirement is to define and have arbitrary Apache configuration. Options persist and/or reapply during updates.
CU need to enable SSO for that he added custom configuration under /etc/httpd/conf.d. When run installer files get disappeared.


Version-Release number of selected component (if applicable):Satellite 6.3


How reproducible: Keep custom configuration file under /etc/httpd/conf.d and then run installer commands file get disappeared.


Steps to Reproduce:
1.
2.
3.

Actual results: Files get disappear.

 
Expected results: File remain as it is or need a mechanism to restore file automatically.


Additional info:

Comment 2 Ewoud Kohl van Wijngaarden 2018-11-13 16:42:19 UTC
There is the option in custom-hiera.yaml:

  apache::purge_configs: false

This will stop the installer from removing unmanaged configs. Do note that this is unsupported because now we can no longer guarantee Apache is in the correct state.

I'll think about a method to achieve the same in a way we can support.

Comment 4 Bryan Kearney 2019-01-31 18:31:38 UTC
Note with comment 2, that the setting is supported but with arbitrary configs the satellite can get into an unknown state. We suggest using custom-heira which we feel will meet most security and performance needs.


Note You need to log in before you can comment on or make changes to this bug.