Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1566310 - Updating a satellite server from 7.4 to 7.5 dependency issue
Summary: Updating a satellite server from 7.4 to 7.5 dependency issue
Keywords:
Status: CLOSED DUPLICATE of bug 1330431
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: krb5
Version: 7.5
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Robbie Harwood
QA Contact: BaseOS QE Security Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 03:15 UTC by Ivan Garcia
Modified: 2018-04-12 17:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-12 17:13:20 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ivan Garcia 2018-04-12 03:15:29 UTC
Description of problem:
rubygem-rkerberos-0.1.3-2.2.el7sat.x86_64 conflicts with the new libkadm5 updated package

Version-Release number of selected component (if applicable):
libkadm5.x86_64 0:1.15.1-8.el7

How reproducible:

yum update -y

Steps to Reproduce:
1. attach satellite subscription 
2. attach redhat server  subcription 
3. update form 7.4 to 7.5  (yum update)

Actual results:

rubygem-rkerberos-0.1.3-2.2.el7sat.x86_64 conflicts with the new libkadm5 updated package. Dependency issues

Expected results:

Server running 7.5 after successful update


Additional info:



--> Running transaction check                                                                                                                                                                                                                                                         
---> Package libkadm5.x86_64 0:1.15.1-8.el7 will be updated                                                                                                                                                                                                                           
--> Processing Dependency: libkadm5clnt_mit.so.8()(64bit) for package: rubygem-rkerberos-0.1.3-2.2.el7sat.x86_64                                                                                                                                                                      
--> Processing Dependency: libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit) for package: rubygem-rkerberos-0.1.3-2.2.el7sat.x86_64                                                                                                                                                   
---> Package libwayland-client.x86_64 0:1.14.0-2.el7 will be installed                                                                                                                                                                                                                
---> Package libwayland-server.x86_64 0:1.14.0-2.el7 will be installed
---> Package lz4.x86_64 0:1.7.5-2.el7 will be installed
---> Package python-inotify.noarch 0:0.9.4-4.el7 will be installed
rhel-7-server-os/filelists                                                                                                                                                                                                                                     |  26 MB  00:00:00
--> Finished Dependency Resolution
Error: Package: rubygem-rkerberos-0.1.3-2.2.el7sat.x86_64 (@rhel-7-server-satellite-6.3-rpms)
           Requires: libkadm5clnt_mit.so.8()(64bit)
           Removing: libkadm5-1.15.1-8.el7.x86_64 (@rhel-7-server-os)
               libkadm5clnt_mit.so.8()(64bit)
           Updated By: libkadm5-1.15.1-19.el7.x86_64 (rhel-7-server-os)
              ~libkadm5clnt_mit.so.11()(64bit)
           Available: krb5-libs-1.11.3-49.el7.x86_64 (rhel-7-server-os)
               libkadm5clnt_mit.so.8()(64bit)
           Available: krb5-libs-1.12.2-14.el7.x86_64 (rhel-7-server-os)
               libkadm5clnt_mit.so.8()(64bit)
           Available: krb5-libs-1.12.2-15.el7_1.x86_64 (rhel-7-server-os)
               libkadm5clnt_mit.so.8()(64bit)
           Available: krb5-libs-1.13.2-10.el7.x86_64 (rhel-7-server-os)
               libkadm5clnt_mit.so.8()(64bit)
           Available: krb5-libs-1.13.2-12.el7_2.x86_64 (rhel-7-server-os)
               libkadm5clnt_mit.so.8()(64bit)
           Available: libkadm5-1.14.1-26.el7.x86_64 (rhel-7-server-os)
               libkadm5clnt_mit.so.8()(64bit)
           Available: libkadm5-1.14.1-27.el7_3.x86_64 (rhel-7-server-os)
               libkadm5clnt_mit.so.8()(64bit)
           Removing: krb5-libs-1.15.1-8.el7.x86_64 (@anaconda/7.4)
               Not found
           Updated By: krb5-libs-1.15.1-19.el7.x86_64 (rhel-7-server-os)
               Not found
           Available: krb5-libs-1.14.1-26.el7.i686 (rhel-7-server-os)
               Not found
           Available: krb5-libs-1.14.1-27.el7_3.i686 (rhel-7-server-os)
               Not found
           Available: krb5-libs-1.15.1-18.el7.i686 (rhel-7-server-os)
               Not found
           Available: libkadm5-1.15.1-18.el7.i686 (rhel-7-server-os)
               Not found
Error: Package: rubygem-rkerberos-0.1.3-2.2.el7sat.x86_64 (@rhel-7-server-satellite-6.3-rpms)
           Requires: libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Removing: libkadm5-1.15.1-8.el7.x86_64 (@rhel-7-server-os)
               libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Updated By: libkadm5-1.15.1-19.el7.x86_64 (rhel-7-server-os)
              ~libkadm5clnt_mit.so.11(kadm5clnt_mit_11_MIT)(64bit)
           Available: krb5-libs-1.11.3-49.el7.x86_64 (rhel-7-server-os)
               libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Available: krb5-libs-1.12.2-14.el7.x86_64 (rhel-7-server-os)
               libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Available: krb5-libs-1.12.2-15.el7_1.x86_64 (rhel-7-server-os)
               libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Available: krb5-libs-1.13.2-10.el7.x86_64 (rhel-7-server-os)
               libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Available: krb5-libs-1.13.2-12.el7_2.x86_64 (rhel-7-server-os)
               libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Available: libkadm5-1.14.1-26.el7.x86_64 (rhel-7-server-os)
               libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Available: libkadm5-1.14.1-27.el7_3.x86_64 (rhel-7-server-os)
               libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Removing: krb5-libs-1.15.1-8.el7.x86_64 (@anaconda/7.4)
               Not found

Comment 2 Robbie Harwood 2018-04-12 17:13:20 UTC
This is a rubygem-rkerberos bug that they have been warned of for two years.

*** This bug has been marked as a duplicate of bug 1330431 ***


Note You need to log in before you can comment on or make changes to this bug.