Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1566327 - dnf crashes with fedora-repos-modular installed
Summary: dnf crashes with fedora-repos-modular installed
Keywords:
Status: CLOSED DUPLICATE of bug 1566344
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F28FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-04-12 05:10 UTC by Mikolaj Izdebski
Modified: 2018-04-12 06:59 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-12 06:59:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Mikolaj Izdebski 2018-04-12 05:10:46 UTC
Description of problem:
After installing fedora-repos-modular on Fedora 28, DNF crashes with ValueError: too many values to unpack (expected 2)

Version-Release number of selected component (if applicable):
dnf-2.7.5-9.fc28.noarch

Steps to Reproduce:
1. Install Fedora 28 (I used Fedora-Cloud-Base-28_Beta-1.3.x86_64)
2. dnf -y --refresh update
3. dnf -y install fedora-repos-modular
4. dnf update

Actual results:
Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 179, in user_main
    errcode = main(args)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 115, in cli_run
    cli.run()
  File "/usr/lib/python3.6/site-packages/dnf/cli/cli.py", line 1015, in run
    self._process_demands()
  File "/usr/lib/python3.6/site-packages/dnf/cli/cli.py", line 768, in _process_demands
    load_available_repos=self.demands.available_repos)
  File "/usr/lib/python3.6/site-packages/dnf/base.py", line 455, in fill_sack
    self._setup_excludes_includes()
  File "/usr/lib/python3.6/site-packages/dnf/base.py", line 196, in _setup_excludes_includes
    self.use_module_includes()
  File "/usr/lib/python3.6/site-packages/dnf/base.py", line 238, in use_module_includes
    update_include_nevras(repo_module.name, repo_module.conf.stream)
  File "/usr/lib/python3.6/site-packages/dnf/base.py", line 230, in update_include_nevras
    include_set, _ = self.repo_module_dict.get_includes(name, stream)
  File "/usr/lib/python3.6/site-packages/dnf/module/repo_module_dict.py", line 165, in get_includes
    version_dependencies = self.get_module_dependency(name, stream)
  File "/usr/lib/python3.6/site-packages/dnf/module/repo_module_dict.py", line 141, in get_module_dependency
    repo_module_version.requires():
ValueError: too many values to unpack (expected 2)

Expected results:
DNF keeps working with modular repos enabded.

Additional info:
This is fixed by https://github.com/rpm-software-management/dnf/pull/1054

Comment 1 Fedora Blocker Bugs Application 2018-04-12 05:11:10 UTC
Proposed as a Blocker for 28-final by Fedora user mizdebsk using the blocker tracking app because:

 The installed system must be able to download and install updates with the default console package manager.

Comment 2 Martin Hatina 2018-04-12 06:59:28 UTC

*** This bug has been marked as a duplicate of bug 1566344 ***


Note You need to log in before you can comment on or make changes to this bug.