Bug 1566366 - [downstream clone - 4.2.4] [RFE] [RHV] Add support to query illegal images in unlock_entity.sh
Summary: [downstream clone - 4.2.4] [RFE] [RHV] Add support to query illegal images in...
Keywords:
Status: CLOSED DUPLICATE of bug 1489968
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.3
: ---
Assignee: Bimal Chollera
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On: 1489968
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 07:42 UTC by RHV bug bot
Modified: 2019-06-26 06:05 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1489968
Environment:
Last Closed: 2018-04-17 07:18:59 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90179 0 master MERGED dbutils: unlock_entity check installed illegal_images info 2018-04-16 12:19:50 UTC
oVirt gerrit 90330 0 ovirt-engine-4.2 MERGED dbutils: unlock_entity check installed illegal_images info 2018-04-16 17:17:45 UTC

Description RHV bug bot 2018-04-12 07:42:49 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1489968 +++
======================================================================

Description of problem:

Currently the /usr/share/ovirt-engine/setup/dbutils/unlock_entity.sh supports unlocking types vm, template, disk and snapshot but not if it's just the image (imagestatus=4).  The other entities of the VM are in correct status but if the image has imagestatus=4, then we need to update the RHV engine database.

Version-Release number of selected component (if applicable):
4.1.5

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

(Originally by Bimal Chollera)

Comment 16 Martin Perina 2018-04-17 07:18:59 UTC
We were able to deliver the fix earlier than expected, so I've retargeted BZ1489968 to RHV 4.2 GA, so closing as duplicate

*** This bug has been marked as a duplicate of bug 1489968 ***

Comment 17 Franta Kust 2019-05-16 13:05:51 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.