Bug 1566376 - OVN Metadata service missing in DVR based environment files
Summary: OVN Metadata service missing in DVR based environment files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Daniel Alvarez Sanchez
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 08:07 UTC by Eran Kuris
Modified: 2018-06-27 13:51 UTC (History)
4 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-0.20180414062830.5f869f2.el7ost
Doc Type: Bug Fix
Doc Text:
The OVN metadata service was not being deployed in DVR based environment. Therefore, instances were not able to fetch metadata such as instance name, public keys, etc. This patch enables the aforementioned service so that any booted instance can fetch metadata.
Clone Of:
Environment:
Last Closed: 2018-06-27 13:50:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1763044 0 None None None 2018-04-12 08:07:19 UTC
OpenStack gerrit 560431 0 None None None 2018-04-12 08:12:31 UTC
OpenStack gerrit 561848 0 None None None 2018-04-17 09:33:07 UTC
Red Hat Product Errata RHEA-2018:2086 0 None None None 2018-06-27 13:51:40 UTC

Description Eran Kuris 2018-04-12 08:07:20 UTC
Description of problem:
OVN DVR environments are currently missing metadata service. This means that instances won't be able to boot properly as they won't be able to retrieve metadata from Nova service.

Version-Release number of selected component (if applicable):
osp13 2018-04-03.3

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 6 Eran Kuris 2018-04-24 06:33:22 UTC
[stack@undercloud-0 ~]$ rpm -qa |grep openstack-tripleo-heat-templates-8
openstack-tripleo-heat-templates-8.0.2-0.20180414062830.5f869f2.el7ost.noarch
[stack@undercloud-0 ~]$ cat core_puddle_version 
2018-04-19.2[stack@undercloud-0 ~]$ cat  /usr/share/openstack-tripleo-heat-templates/environments/services-docker/neutron-ovn-dvr-ha.yaml
parameter_defaults:
    NeutronEnableDHCPAgent: false
    NeutronEnableDVR: true
    NeutronMechanismDrivers: ovn
    NeutronNetworkType: vlan
    NeutronServicePlugins: qos,ovn-router,trunk
    NeutronTypeDrivers: geneve,vlan,flat
    NeutronVniRanges:
    - 1:65536
    OVNNeutronSyncMode: log
    OVNQosDriver: ovn-qos
    OVNTunnelEncapType: geneve
    OVNVifType: ovs
resource_registry:
    OS::TripleO::Docker::NeutronMl2PluginBase: ../../puppet/services/neutron-plugin-ml2-ovn.yaml
    OS::TripleO::Services::ComputeNeutronCorePlugin: OS::Heat::None
    OS::TripleO::Services::ComputeNeutronOvsAgent: OS::Heat::None
    OS::TripleO::Services::NeutronDhcpAgent: OS::Heat::None
    OS::TripleO::Services::NeutronL3Agent: OS::Heat::None
    OS::TripleO::Services::NeutronMetadataAgent: OS::Heat::None
    OS::TripleO::Services::NeutronOvsAgent: OS::Heat::None
    OS::TripleO::Services::OVNController: ../../docker/services/ovn-controller.yaml
    OS::TripleO::Services::OVNDBs: ../../docker/services/pacemaker/ovn-dbs.yaml
    OS::TripleO::Services::OVNMetadataAgent: ../../docker/services/ovn-metadata.yaml
fixed

Comment 8 errata-xmlrpc 2018-06-27 13:50:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.