Bug 1566386 - Disable choose-local in groups virt and gluster-block
Summary: Disable choose-local in groups virt and gluster-block
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: unclassified
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1568297
TreeView+ depends on / blocked
 
Reported: 2018-04-12 08:27 UTC by Krutika Dhananjay
Modified: 2018-06-20 18:04 UTC (History)
2 users (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1568297 (view as bug list)
Environment:
Last Closed: 2018-06-20 18:04:29 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Krutika Dhananjay 2018-04-12 08:27:41 UTC
Description of problem:

Sometime back when I was working on improving gluster performance for hyperconverged vm store workload, I'd seen ~6-8K iops improvement with random read fio test (run from 3 vms hosted on gluster volume).

Even Manoj (cc'd) reported better performance on gluster-block with choose-local disabled.

We're proposing to disable the option in groups virt and gluster-block in light of the above.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Worker Ant 2018-04-12 08:30:28 UTC
REVIEW: https://review.gluster.org/19855 (extras: Disable choose-local in groups virt and gluster-block) posted (#1) for review on master by Krutika Dhananjay

Comment 3 Worker Ant 2018-04-13 10:23:30 UTC
COMMIT: https://review.gluster.org/19855 committed in master by "Pranith Kumar Karampuri" <pkarampu@redhat.com> with a commit message- extras: Disable choose-local in groups virt and gluster-block

Change-Id: Icba68406d86623195d59d6ee668e0850c037c63a
fixes: bz#1566386
Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>

Comment 4 Shyamsundar 2018-06-20 18:04:29 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.