Bug 1566402 - [JNPE] VM could not be started / at org.ovirt.engine.core.vdsbroker.builder.vminfo.LibvirtVmXmlBuilder.lambda$writeInterfaces$23(LibvirtVmXmlBuilder.java:1091)
Summary: [JNPE] VM could not be started / at org.ovirt.engine.core.vdsbroker.builder.v...
Keywords:
Status: CLOSED DUPLICATE of bug 1570349
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core
Version: 4.2.2.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.2.4
: ---
Assignee: Arik
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 09:07 UTC by Jiri Belka
Modified: 2018-05-06 07:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-06 07:59:46 UTC
oVirt Team: Virt
rule-engine: ovirt-4.2+


Attachments (Terms of Use)

Description Jiri Belka 2018-04-12 09:07:19 UTC
Description of problem:

we were trying to start pmatyas-host-01 and it failed, running later was ok. also something odd appeared in UI, but unfortunatelly I did not save it :/

2018-04-12 10:46:34,249+02 INFO  [org.ovirt.engine.core.vdsbroker.CreateVDSCommand] (default task-7) [21c0e7ba-790c-4e00-af3e-b73aae692c9b] START, CreateVDSCommand( CreateVDSCommandParameters:{hostId='94083e18-550c-428c-8abc-0e4bc9839e4e
', vmId='eb91d238-1a2c-4588-8f22-73cac948006e', vm='VM [pmatyas-host-01]'}), log id: 657b2d31

...
2018-04-12 10:46:34,259+02 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateBrokerVDSCommand] (default task-7) [21c0e7ba-790c-4e00-af3e-b73aae692c9b] Failed in 'CreateBrokerVDS' method, for vds: 'slot-7b'; host: 'slot-7b.rhev.lab.e
ng.brq.redhat.com': null
2018-04-12 10:46:34,259+02 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateBrokerVDSCommand] (default task-7) [21c0e7ba-790c-4e00-af3e-b73aae692c9b] Command 'CreateBrokerVDSCommand(HostName = slot-7b, CreateVDSCommandParameters:{h
ostId='94083e18-550c-428c-8abc-0e4bc9839e4e', vmId='eb91d238-1a2c-4588-8f22-73cac948006e', vm='VM [pmatyas-host-01]'})' execution failed: null
2018-04-12 10:46:34,260+02 DEBUG [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateBrokerVDSCommand] (default task-7) [21c0e7ba-790c-4e00-af3e-b73aae692c9b] Exception: java.lang.NullPointerException
        at org.ovirt.engine.core.vdsbroker.builder.vminfo.LibvirtVmXmlBuilder.lambda$writeInterfaces$23(LibvirtVmXmlBuilder.java:1091) [vdsbroker.jar:]
        at java.util.Comparator.lambda$comparing$77a9974f$1(Comparator.java:469) [rt.jar:1.8.0_161]
        at java.util.TimSort.countRunAndMakeAscending(TimSort.java:355) [rt.jar:1.8.0_161]
        at java.util.TimSort.sort(TimSort.java:220) [rt.jar:1.8.0_161]
        at java.util.Arrays.sort(Arrays.java:1512) [rt.jar:1.8.0_161]
        at java.util.stream.SortedOps$SizedRefSortingSink.end(SortedOps.java:348) [rt.jar:1.8.0_161]
        at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:482) [rt.jar:1.8.0_161]
        at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:471) [rt.jar:1.8.0_161]
        at java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:151) [rt.jar:1.8.0_161]
        at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:174) [rt.jar:1.8.0_161]
...
2018-04-12 10:46:34,286+02 ERROR [org.ovirt.engine.core.vdsbroker.CreateVDSCommand] (default task-7) [21c0e7ba-790c-4e00-af3e-b73aae692c9b] Command 'CreateVDSCommand( CreateVDSCommandParameters:{hostId='94083e18-550c-428c-8abc-0e4bc9839e4e', vmId='eb91d238-1a2c-4588-8f22-73cac948006e', vm='VM [pmatyas-host-01]'})' execution failed: java.lang.NullPointerException
2018-04-12 10:46:34,286+02 DEBUG [org.ovirt.engine.core.vdsbroker.CreateVDSCommand] (default task-7) [21c0e7ba-790c-4e00-af3e-b73aae692c9b] Exception: java.lang.RuntimeException: java.lang.NullPointerException
        at org.ovirt.engine.core.vdsbroker.CreateVDSCommand.executeVmCommand(CreateVDSCommand.java:68) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.ManagingVmCommand.executeVDSCommand(ManagingVmCommand.java:17) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.VDSCommandBase.executeCommand(VDSCommandBase.java:73) [vdsbroker.jar:]
        at org.ovirt.engine.core.dal.VdcCommandBase.execute(VdcCommandBase.java:33) [dal.jar:]
        at org.ovirt.engine.core.vdsbroker.vdsbroker.DefaultVdsCommandExecutor.execute(DefaultVdsCommandExecutor.java:14) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.ResourceManager.runVdsCommand(ResourceManager.java:398) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.ResourceManager$Proxy$_$$_WeldSubclass.runVdsCommand$$super(Unknown Source) [vdsbroker.jar:]
        at sun.reflect.GeneratedMethodAccessor91.invoke(Unknown Source) [:1.8.0_161]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.8.0_161]
        at java.lang.reflect.Method.invoke(Method.java:498) [rt.jar:1.8.0_161]

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.2.6-0.1.el7.noarch

How reproducible:
1 in 1

Steps to Reproduce:
1. 
2.
3.

Actual results:
a vm could not be started, odd output in ui and jnpe in engine.log

Expected results:
at least clear message why it could not run

Additional info:

Comment 2 Arik 2018-04-26 12:36:17 UTC
Jiri, did that VM ever started properly after upgrading your hosts? if not, do you remember if you put your hosts into maintenance when upgrading them? I'm asking that because it seems like a duplicate of [1]

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1570349

Comment 3 Arik 2018-05-06 07:59:46 UTC
(In reply to Arik from comment #2)
> Jiri, did that VM ever started properly after upgrading your hosts? if not,
> do you remember if you put your hosts into maintenance when upgrading them?
> I'm asking that because it seems like a duplicate of [1]
> 
> [1] https://bugzilla.redhat.com/show_bug.cgi?id=1570349

Closing as a duplicate, feel free to reopen if you think it is not the case.

*** This bug has been marked as a duplicate of bug 1570349 ***


Note You need to log in before you can comment on or make changes to this bug.