Bug 1566415 - [Docs][Admin] recommended way of non-disrupting migration to iSCSI Bond
Summary: [Docs][Admin] recommended way of non-disrupting migration to iSCSI Bond
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.1.9
Hardware: x86_64
OS: Linux
high
low
Target Milestone: ovirt-4.2.7
: ---
Assignee: Avital Pinnick
QA Contact: Tahlia Richardson
URL:
Whiteboard: docs-accepted
: 1565198 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 09:19 UTC by Olimp Bockowski
Modified: 2019-05-07 12:45 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-01 06:04:02 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)

Description Olimp Bockowski 2018-04-12 09:19:58 UTC
Description of problem:

There is a need to test and document a recommended way how to make an existing RHV environment to utilize iSCSI bond feature (using the same subnet). We have a quite spare (in the matter of scenarios) description of iSCSI Bond in the "Administration Gude"

https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.1/html/administration_guide/sect-preparing_and_adding_block_storage#Configuring_iSCSI_Multipathing

However, most customers start their settings from a simple setting and then they want to migrate to iSCSI bond.

This doc BZ was created from https://bugzilla.redhat.com/show_bug.cgi?id=1565198
Before we publish the recommended way, we have to test using continuous IO. 

Version-Release number of selected component (if applicable):

RHV 4.x

How reproducible:

Let's take into consideration the worst case, e.g customer has a bond (from 2 NICs), on top of it Logical Network (responsible for a storage connection). Now he wants to move it (without downtime) to iSCSI bond using the same subnet. I have tested such scenario, it is working properly: I broke the bond, prepared Logical Networks (not-required), attached to NICs, created iSCSI Bond, everything on a running hypervisor. It seems to be ok, but I afraid to give recommendations for production environments.

Actual results:
It is working properly

Expected results:
We need to have a confirmation that VMs running on a host are not affected and nothing wrong with their I/O operations.

Comment 3 Yaniv Lavi 2018-08-13 08:54:32 UTC
*** Bug 1565198 has been marked as a duplicate of this bug. ***

Comment 12 Elad 2018-10-28 08:49:44 UTC
The flow of migrating storage traffic from mgmt network to dedicated storage network using iSCSI bond was tested.


Note You need to log in before you can comment on or make changes to this bug.