Bug 1566417 - [Disperse] Assertion failed: ec_get_inode_size(fop, fop->locks[0].lock->loc.inode, &cbk->iatt[0].ia_size) errors in rebalance logs
Summary: [Disperse] Assertion failed: ec_get_inode_size(fop, fop->locks[0].lock->loc.i...
Keywords:
Status: CLOSED DUPLICATE of bug 1398196
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: disperse
Version: rhgs-3.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Ashish Pandey
QA Contact: Nag Pavan Chilakam
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 09:26 UTC by Prasad Desala
Modified: 2018-09-10 06:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-13 09:53:04 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Prasad Desala 2018-04-12 09:26:28 UTC
Description of problem:
=======================
Seeing below assertion failed errors in rebalance logs when rebalance is running,
Assertion failed: ec_get_inode_size(fop, fop->locks[0].lock->loc.inode, &cbk->iatt[0].ia_size) errors in rebalance logs

Version-Release number of selected component (if applicable):
3.12.2-7.el7rhgs.x86_64

How reproducible:
1/1

Steps to Reproduce:
===================
1) Create Distributed-Disperse volume and start it.
2) FUSE mount it on multiple clients
3) From clients start below operations,
Create two dirs 1 and 2 on the mount point.
Client-1: Linux kernel untar --> tar -xvf linux-4.9.27.tar.gz -C 1
Client-2: Linux kernel untar --> tar -xvf linux-4.9.27.tar.gz -C 2
Client-3: while true; do ls -lRt;done
Client-4: while true; do find . |xargs stat ;done
4) Now add-bricks and trigger rebalance without force option.
5) Wait till the rebalance completes. 

Actual results:
===============
Seeing below assertion failed errors in rebalance logs,
Assertion failed: ec_get_inode_size(fop, fop->locks[0].lock->loc.inode, &cbk->iatt[0].ia_size) errors in rebalance logs

Expected results:
=================
No assertions in rebalance logs.

Comment 5 Ashish Pandey 2018-04-13 09:53:04 UTC

*** This bug has been marked as a duplicate of bug 1398196 ***


Note You need to log in before you can comment on or make changes to this bug.