Bug 1566435 - fail to upgrade when backup etcd due to wrong etcdctl command was set
Summary: fail to upgrade when backup etcd due to wrong etcdctl command was set
Keywords:
Status: CLOSED DUPLICATE of bug 1566238
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 3.9.z
Assignee: Scott Dodson
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 10:15 UTC by liujia
Modified: 2018-04-17 13:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-17 13:17:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1566238 0 unspecified CLOSED upgrade from v3.7 to v3.9 fails with openshift-ansible-3.9.20-1.git.0.f99fb43.el7 2021-02-22 00:41:40 UTC

Internal Links: 1566238

Description liujia 2018-04-12 10:15:10 UTC
Description of problem:
Fail to upgrade ocp v3.7 to latest v3.9 when backup etcd due to wrong etcdctl command was set.

TASK [etcd : Generate etcd backup] *********************************************
task path: /usr/share/ansible/openshift-ansible/roles/etcd/tasks/backup/backup.yml:52
fatal: [x.x.x.x]: FAILED! => {"changed": false, "cmd": "runc exec etcd etcdctl backup --data-dir=/var/lib/etcd/ --backup-dir=/var/lib/etcd//openshift-backup-pre-upgrade-20180412085041", "msg": "[Errno 2] No such file or directory", "rc": 2}

#roles/etcd/defaults/main.yaml
r_etcd_common_etcdctl_command: "{{ 'etcdctl' if r_etcd_common_etcd_runtime == 'host' | bool else 'docker exec etcd_container etcdctl' if r_etcd_common_etcd_runtime == 'docker' else 'runc exec etcd etcdctl' }}"


Version-Release number of the following components:
openshift-ansible-3.9.20-1.git.0.f99fb43.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. RPM install ocp v3.7
2. Run upgrade to v3.9
3.

Actual results:
Upgrade failed.

Expected results:
Upgrade succeed.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Russell Teague 2018-04-17 13:17:10 UTC

*** This bug has been marked as a duplicate of bug 1566238 ***


Note You need to log in before you can comment on or make changes to this bug.