Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1566440 - Selection of ibus candidates using mouse does not work in Gnome
Summary: Selection of ibus candidates using mouse does not work in Gnome
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 10:34 UTC by Bhushan Barve
Modified: 2018-10-29 11:13 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-29 11:13:18 UTC
Type: Bug


Attachments (Terms of Use)

Description Bhushan Barve 2018-04-12 10:34:54 UTC
Description of problem: When typing booster is enabled, user is not able to select from candidate selection window using mouse. Previously it used to work with mouse when checked in F27. 


Version-Release number of selected component (if applicable):
F28 beta

How reproducible:
always

Steps to Reproduce:
1. select any typing-booster input method from control-center.
2. open gedit or any other editor
3. start typing
4. when the candidate selection window appears, try to select any option using mouse

Actual results:
selection using mouse does not work

Expected results:
User should be able to select candidate using mouse too.

Additional info:

Comment 1 Mike FABIAN 2018-04-16 13:54:07 UTC
That seems to be a Gnome problem.

When using XFCE, selecting candidates with the mouse works, both 
when using ibus-typing-booster and when using ibus-kkc.

But when using Gnome (Wayland), it does not work neither for
ibus-typing-booster nor for ibus-kkc.

Comment 2 Mike FABIAN 2018-04-16 13:55:55 UTC
Same when using Gnome under Xorg, selecting candidates with the mouse does not work.

Comment 3 Mike FABIAN 2018-04-16 13:58:12 UTC
Move to Gnome shell.

Comment 4 fujiwara 2018-04-18 04:42:02 UTC
Seems there is a typo.
I filed a merge request.
https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/81


Note You need to log in before you can comment on or make changes to this bug.