Bug 1566457 - Hot plug CPU is broken on 3.6 clusters after oVirt is upgraded to 4.2
Summary: Hot plug CPU is broken on 3.6 clusters after oVirt is upgraded to 4.2
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Database.Core
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.2.3
: 4.2.3.2
Assignee: Eli Mesika
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 11:04 UTC by Eli Mesika
Modified: 2019-04-28 10:47 UTC (History)
8 users (show)

Fixed In Version: ovirt-engine-4.2.3.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 06:29:45 UTC
oVirt Team: Infra
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90213 0 master MERGED db:fix HotPlugCpuSupported value for x86 in 3.6 2018-04-16 11:38:49 UTC
oVirt gerrit 90329 0 ovirt-engine-4.2 MERGED db:fix HotPlugCpuSupported value for x86 in 3.6 2018-04-16 17:17:13 UTC
oVirt gerrit 1566457 0 None None None 2018-04-12 12:19:14 UTC

Description Eli Mesika 2018-04-12 11:04:36 UTC
Description of problem:

 When upgrading oVirt a 3.6 cluster losses its Hot plug cpu functionality since the config setting for that key has a wrong value 


Version-Release number of selected component (if applicable):


How reproducible:

Always


Steps to Reproduce:
1.Have a 3.6 cluster in oVirt 3.6 with Hot plug CPU used 
2.Upgrade oVirt to 4.2 
3.Test  Hot plug CPU on the 3.6 cluster


Actual results:

3.6 cluster losses its Hot plug CPU functionality


Expected results:

3.6 cluster should support plug CPU functionality


Additional info:

The reason for this regression was a missing value in the config file for 3.6 and then he value was taken from the java code which was correct 
However, getting rid from config defaults in the java code and a wrong setting that was added to the config file broke the feature

Comment 1 Israel Pinto 2018-04-23 08:00:23 UTC
Verify with:
Engine version:4.2.3.2-0.1.el7

Hot plug CPU to VM in 3.6 cluster on 4.2 engine

Comment 2 Sandro Bonazzola 2018-05-10 06:29:45 UTC
This bugzilla is included in oVirt 4.2.3 release, published on May 4th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.