Bug 1566465 - Puppet -4"command line utility does not correctly modify puppet.conf as it used to do in puppet-3 "
Summary: Puppet -4"command line utility does not correctly modify puppet.conf as it us...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Puppet
Version: 6.3.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Peter Ondrejka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 11:28 UTC by Amaani S Karimi
Modified: 2019-12-03 12:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-03 12:54:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3412271 0 None None None 2018-04-14 07:40:28 UTC

Description Amaani S Karimi 2018-04-12 11:28:02 UTC
Description of problem:

In puppet 3 useing 'puppet config --section main set <option> <value>' to create an initial configuration for our Puppet agents, It worked well and created a file with content:

    [main]
    <option> = <value>

When performing the same operation with the Puppet 4 utility the parameter gets added directly to the top of the file but NOT within the 'main' section. it will not create the 'main' section in a new/empty puppet.conf file.




Version-Release number of selected component (if applicable):
Red Hat satellite 6.3 
Puppet 4 



How reproducible:

100% reproducible.

after performing the same steps as proposed in the description 
I was able to see that the append of an option is done at the top of the configuration file and not in the main section as it was happening in puppet 3.


Actual results:

The entries are added at the top of the configuration file and no main section is created.

Expected results:

the entries should be created in the main section of the puppet.conf file.

Comment 2 Bryan Kearney 2019-11-04 14:34:23 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 3 Bryan Kearney 2019-12-03 12:54:07 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.