Bug 156652 - Installer exits with 'install exited abnormally' after beginning RPM transaction
Installer exits with 'install exited abnormally' after beginning RPM transaction
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-02 17:37 EDT by Peter Guyan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-05 17:27:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Guyan 2005-05-02 17:37:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624 Netscape/7.1

Description of problem:
Trying to install FC3 over an nfs export.

I've copied the contents of the DVD to a directory '/os/fc3', removed all 'TRANS.TBL' files.

I've also copied accross updated RPMS downloaded from http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/i386/ 
manually removed all duplicate packages.

Used pkgorder and genhdlist to update.
pkgorder /os/fc3/ i386 Fedora > /os/fc3/pkgfile
genhdlist --withnumbers --productpath=Fedora --fileorder /os/fc3/pkgfile /os/fc3

Using PXE to boot the installer, using NFS as a method, selected 'Personal Desktop' as the install type. 

Installer goes through formatting partitions, displays the 'Beginning RPM Transaction' window.

As soon as the progress bar reaches the end, the installer exits with 'install exited abnormally'.

I've tried this with all intall types, with 'Custom' it hangs before going any further.

Have also tried with a kickstart file created from using the DVD as the install method.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Copy DVD to a /install/base
2. find /install/base -name TRANS.TBL -exec rf -f {} \;
3. Copy Updated RPMS to /install/base/Fedora/RPMS
4. pkgorder /install/base i386 Fedora > /install/base/pkgfile
5. genhdlist --withnumbers --productpath=Fedora --fileorder /install/base/pkgfile /install/base
6. Export /install/base from NFS server
7. Boot installation media  
8. Go through installation and select 'Personal Desktop'
9. watch it die after setting up RPM transaction

Actual Results:  Installer Died

Expected Results:  Installation to work

Additional info:
Comment 1 Jeremy Katz 2005-05-05 17:27:00 EDT
You need to do genhdlist, pkgorder, genhdlist.  Things should be a little bit
more tolerant of this problem in FC4.

Note You need to log in before you can comment on or make changes to this bug.