Bug 1566523 - Metrics playbook is not idempotent
Summary: Metrics playbook is not idempotent
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-metrics
Classification: oVirt
Component: Generic
Version: unspecified
Hardware: All
OS: All
unspecified
medium
Target Milestone: ovirt-4.2.3
: ---
Assignee: Shirly Radco
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 13:04 UTC by Lukas Svaty
Modified: 2018-05-10 06:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 06:32:49 UTC
oVirt Team: Metrics
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90235 0 master MERGED Ignore failure when externalIP is already set 2018-04-12 15:57:35 UTC

Description Lukas Svaty 2018-04-12 13:04:52 UTC
Description of problem:
configure_metrics playbook fails on patching externalIPs of the container as it is already set by previous run, therefore breaking idempotency of ansible

Version-Release number of selected component (if applicable):
ovirt-engine-metrics-1.1.4-0.0.master.20180408064245.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. /usr/share/ovirt-engine-metrics/configure_ovirt_machines_for_metrics.sh
2. /usr/share/ovirt-engine-metrics/configure_ovirt_machines_for_metrics.sh
3.

Actual results:
TASK [oVirt.metrics/roles/oVirt.metrics-store-setup : Assign an IP Address to the Elasticsearch Service] **********************************************************************************************************
fatal: [10-37-138-124.rhev.lab.eng.brq.redhat.com]: FAILED! => {"changed": true, "cmd": "oc patch svc logging-es -p '{\"spec\":{\"externalIPs\":[\"10.37.138.124\"]}}'", "delta": "0:00:00.987452", "end": "2018-04-12 14:58:03.210222", "msg": "non-zero return code", "rc": 1, "start": "2018-04-12 14:58:02.222770", "stderr": "", "stderr_lines": [], "stdout": "service \"logging-es\" not patched", "stdout_lines": ["service \"logging-es\" not patched"]}


Expected results:
Check if externalIPs are set, if they are, do not patch

Comment 1 Lukas Svaty 2018-04-19 13:16:13 UTC
patch not included in ovirt-engine-metrics-1.1.4-1.el7ev.noarch

please make sure ovirt-milestone is correct

Comment 2 Lukas Svaty 2018-04-19 13:17:27 UTC
apologies, updated wrong bug, verified in ovirt-engine-metrics-1.1.4-1.el7ev.noarch

Comment 3 Sandro Bonazzola 2018-05-10 06:32:49 UTC
This bugzilla is included in oVirt 4.2.3 release, published on May 4th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.