Bug 1566578 - RHEL 7.4 can not update because somepackages are not in RHEL-7-Server repository
Summary: RHEL 7.4 can not update because somepackages are not in RHEL-7-Server repository
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: container-selinux
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lokesh Mandvekar
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 14:49 UTC by jooho lee
Modified: 2018-06-05 20:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-13 06:35:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description jooho lee 2018-04-12 14:49:13 UTC
Description of problem:
With specific release "7.4" of subscription-manager, it failed to update because following version of packages are not in the repository.

- selinux-policy-base
- selinux-policy
- selinux-policy-targeted

version: 3.13.1-192.el7_5.3 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.subscription-manager release --set 7.4
2.yum clean all; yum repolist
3.yum update

Actual results:

dependencies errors
~~~
Error: Package: 2:container-selinux-2.55-1.el7.noarch (rhel-7-server-extras-rpms)
           Requires: selinux-policy >= 3.13.1-183
           Removing: selinux-policy-3.13.1-102.el7.noarch (@anaconda/7.3)
               selinux-policy = 3.13.1-102.el7
           Updated By: selinux-policy-3.13.1-166.el7_4.9.noarch (rhel-7-server-rpms)
               selinux-policy = 3.13.1-166.el7_4.9
           Available: selinux-policy-3.12.1-153.el7.noarch (rhel-7-server-rpms)
...
..
~~~

Expected results:
No errors.

Additional info:

Comment 2 Craig Donnelly 2018-04-12 15:32:14 UTC
This is not a bug.

Error: Package: 2:container-selinux-2.55-1.el7.noarch (rhel-7-server-extras-rpms)

This package is only available in rhel-extras.
If you are using items in extras, you are expected to be on the latest release, per: https://access.redhat.com/support/policy/updates/extras/

You could use an unsupported solution of version locking packages to get your updates to continue, or perhaps a repo-override via subscription-manager to point extras at the 7.4 tree (which does exist, but is not configurable via release within sub-man/entitlements).

Comment 3 Panu Matilainen 2018-04-13 06:35:00 UTC
In particular it's not a bug in the rpm software, which is what the component "rpm" is about. As a general rule: if in doubt, problems concerning package X should be filed on component X.


Like Craig pointed out, Extras policy is what it is, so this is hardly a bug.


Note You need to log in before you can comment on or make changes to this bug.