Bug 15666 - rc.sysinit should leave the HOSTNAME alone when it is already set.
rc.sysinit should leave the HOSTNAME alone when it is already set.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-07 13:27 EDT by Aleksey Nogin
Modified: 2014-03-16 22:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-07 15:12:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix it. Also prevents rc.sysinit from creating /etc/HOSTNAME - see my comments on BUG #3906 (640 bytes, patch)
2000-08-07 14:00 EDT, Aleksey Nogin
no flags Details | Diff

  None (edit)
Description Aleksey Nogin 2000-08-07 13:27:09 EDT
When IP setup is done by the kernel (using DHCP), the hostname is already
set by the kernel before rc.sysinit is started. rc.sysinit should detect it
at leave it alone.
Comment 1 Aleksey Nogin 2000-08-07 14:00:48 EDT
Created attachment 2216 [details]
Patch to fix it. Also prevents rc.sysinit from creating /etc/HOSTNAME - see my comments on BUG #3906
Comment 2 Bill Nottingham 2000-08-07 14:32:12 EDT
Out of curiousity, what are you doing with a bunch of NFS root
machines that's causing this spate of bugs? :)
Comment 3 Aleksey Nogin 2000-08-07 15:12:38 EDT
We have a 16x2 cluster running RH 6.2. We've set the slave nodes to mount
root-over-NFS from the master node (they all mount the same partition withe the
same config files and because of that we do all the network configuration
through kernel-DHCP). Our latest achievment is mounting the root FS read-only
(but with no_root_squash) - it prints a buch of warnings about being unable to
change things like /etc/issue, but boots fine. The slave nodes have their own
HDs that we use for things like /tmp, /var and  swap,  but this root-on-NFS
makes administering much easier than giving each of the slaves its own copy of
RedHat.

The only thing that we had to change and that I haven't submitted as a bug is
that we had to make /etc/mtab a symlink to /proc/mounts - works surprizingly
well (even when root FS was RW, nobody tried to replace the symlink with
something else). Of course the better solution would be for all the
mount-related programs to know to leave /etc/mtab alone when /proc is available
(at least not to consider failure to change /etc/mtab to be critical), but I am
not sure if it's worth the effort.
Comment 4 Bill Nottingham 2000-08-07 17:07:52 EDT
Neat. I'm not sure about the mtab vs. /proc/mounts, but
I doubt we'd make one a symlink to another.

Fixed in CVS, will be in 5.40-somethingorother.

Note You need to log in before you can comment on or make changes to this bug.