Bug 1566643 - tcmu-runner systemd unit file should stop/restart ceph-iscsi-gw unit
Summary: tcmu-runner systemd unit file should stop/restart ceph-iscsi-gw unit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: iSCSI
Version: 3.0
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: 3.1
Assignee: Jason Dillaman
QA Contact: Manohar Murthy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 16:41 UTC by Jason Dillaman
Modified: 2018-09-26 18:20 UTC (History)
3 users (show)

Fixed In Version: tcmu-runner-1.4.0-0.1.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-26 18:19:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2819 0 None None None 2018-09-26 18:20:44 UTC

Description Jason Dillaman 2018-04-12 16:41:23 UTC
Description of problem:
tcmu-runner cannot gracefully handle restarting when there is active IO and the fix requires a kernel change. In the meantime, the workaround for this issue is to stop the ceph-iscsi-gw service first (so that the gateway is cleanly shut down), restart tcmu-runner, and then restart ceph-iscsi-gw to bring the target portal back online.

Version-Release number of selected component (if applicable):
1.3

How reproducible:
100%

Steps to Reproduce:
1. attempt to restart tcmu-runner with active IO workloas

Actual results:
The process will hang and/or crash.

Expected results:
You can gracefully restart the daemon.

Additional info:

Comment 8 errata-xmlrpc 2018-09-26 18:19:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2819


Note You need to log in before you can comment on or make changes to this bug.