Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1566671 - Routers unresponsive
Summary: Routers unresponsive
Keywords:
Status: CLOSED DUPLICATE of bug 1384746
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 3.3.1
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: ---
Assignee: Ben Bennett
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 18:27 UTC by Robert Bost
Modified: 2018-04-12 21:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-12 21:55:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Robert Bost 2018-04-12 18:27:57 UTC
Description of problem:

Customer is having an outage due to their router pods being unresponsive. Removing health checks allows pods to start up but performing health checks manually (curl http://localhost:1936/healthz) still fail after a long pause with Connection Timeout.

Unfortunately, no events or logging output from haproxy.

Version-Release number of selected component (if applicable): atomic-openshift-3.3.1.17-1.git.0.b82e86c


How reproducible: Happening constantly for customer.


Actual results: Unable to utilize pod routes.

Comment 3 Ben Bennett 2018-04-12 18:58:09 UTC
I think the iptables errors are a red herring since the router runs with host networking and a service is not being used to access it.

What's the cpu utilization of haproxy?  Is it under high load?

Comment 4 Ryan Howe 2018-04-12 21:55:00 UTC

*** This bug has been marked as a duplicate of bug 1384746 ***


Note You need to log in before you can comment on or make changes to this bug.