Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1566741 - Date entry in GNUCash 3.0 in F28 is completely unusable in Persian
Summary: Date entry in GNUCash 3.0 in F28 is completely unusable in Persian
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnucash
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 22:03 UTC by Hedayat Vatankhah
Modified: 2019-02-21 04:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-21 04:16:54 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 795247 0 Normal RESOLVED datepicker broken in Persian 2020-07-17 22:07:24 UTC

Description Hedayat Vatankhah 2018-04-12 22:03:15 UTC
Description of problem:
The Date column in an accounts data entry is completely useless. I cannot select today at all. With every click, it jumps to another year! Also, using -/+ buttons to go to prev/next day doesn't work! both of them decrease the year field.

Also, just clicking on a row will change its date!

Summary: it is completely useless!

Version-Release number of selected component (if applicable):
gnucash-3.0-1.fc28.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Run GnuCash
2. Create a new file
3. Go to an account and try to enter a new row

Or
Open an existing file (From GnuCash 2.6)
Open an account and select a row and see its date is modified


Actual results:


Expected results:


Additional info:

Comment 1 Hedayat Vatankhah 2018-04-13 19:32:24 UTC
Tried with export LC_TIME=en_US.UTF-8, and it worked fine.
The bug happens when LC_TIME=fa_IR.UTF-8 (and probably some other locales).

Comment 2 Bill Nottingham 2018-04-14 04:52:32 UTC
I've reproduced this, but only for Farsi so far - other RTL languages such as Hebrew and Arabic work.

Sent upstream https://bugzilla.gnome.org/show_bug.cgi?id=795247.

Comment 3 Hedayat Vatankhah 2018-04-14 13:14:47 UTC
Thanks :)

Comment 4 Bill Nottingham 2019-02-21 04:16:54 UTC
This got fixed in 3.2.


Note You need to log in before you can comment on or make changes to this bug.