Bug 1566785 - `oc delete all --all` cannot delete the ingress resource
Summary: `oc delete all --all` cannot delete the ingress resource
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.10.0
Hardware: All
OS: All
medium
low
Target Milestone: ---
: ---
Assignee: Maciej Szulik
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 01:41 UTC by zhaozhanqi
Modified: 2019-02-27 21:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-27 21:47:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description zhaozhanqi 2018-04-13 01:41:31 UTC
Description of problem:
When using `oc delete all --all` to delete all resource. found the ingress did not been removed.
since for now the ingress resource can be created by normal user just like route. So this resource should be added to the 'all' list.

Version-Release number of selected component (if applicable):
v3.10.0-0.16.0

How reproducible:
always

Steps to Reproduce:
1. create ingress 
   oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/routing/ingress/test-ingress.json
2. using the following command:
   oc delete all --all
3.

Actual results:
 the ingress resource did not been removed

Expected results:
 the ingress resource should be deleted.

Additional info:

Comment 1 Juan Vallejo 2018-04-13 15:22:36 UTC
Upstream PR: https://github.com/kubernetes/kubernetes/pull/62546

Comment 4 Maciej Szulik 2019-02-27 21:47:13 UTC
Based on the feedback on the upstream PR this won't be solved.


Note You need to log in before you can comment on or make changes to this bug.