Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1566823 - fuse: synthetic stavfs values are confusing
Summary: fuse: synthetic stavfs values are confusing
Keywords:
Status: CLOSED DUPLICATE of bug 1523219
Alias: None
Product: GlusterFS
Classification: Community
Component: fuse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 04:29 UTC by Csaba Henk
Modified: 2018-04-13 04:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-13 04:37:14 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Csaba Henk 2018-04-13 04:29:29 UTC
Description of problem:

Instead of passing over the respective values obtained from backend, fuse xlator specifies stavfs values (in particular, f_{b,fr}size) on its own.

This is confusing as the size granularity, and therefore the fs sizes reported by df and similar tools will differ within different protocols.

See http://lists.gluster.org/pipermail/gluster-devel/2018-March/054660.html for more background on the phenomenon.

Comment 1 Csaba Henk 2018-04-13 04:37:14 UTC

*** This bug has been marked as a duplicate of bug 1523219 ***


Note You need to log in before you can comment on or make changes to this bug.