Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1566867 - gnome-classic-session requires gnome-shell-extension-top-icons in optional repository. It causes update failure to RHEL7.5
Summary: gnome-classic-session requires gnome-shell-extension-top-icons in optional re...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng
Version: 7.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Release Engineering Bug Triage
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 06:22 UTC by Keigo Noha
Modified: 2018-05-29 12:14 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-29 12:14:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3410791 0 None None None 2018-04-16 02:07:31 UTC

Description Keigo Noha 2018-04-13 06:22:49 UTC
Description of problem:
gnome-classic-session requires gnome-shell-extension-top-icons in optional repository. It causes update failure to RHEL7.5

Version-Release number of selected component (if applicable):
RHEL7.5

How reproducible:
100%

Steps to Reproduce:
1. Install RHEL7.4 as 'Server with GUI'.
2. Register the system to Customer Portal.
3. Run 'yum update' to update the machine to RHEL7.5 

Actual results:
Currently, the update process is failed by the dependency to gnome-shell-extension-top-icons package.

Expected results:
The update process should not be failed.

Additional info:
gnome-shell-extension-top-icons package is in optional repository.
Until RHEL7.4, this optional package is not required.

Comment 9 Lubos Kocman 2018-05-11 13:03:12 UTC
Hello team

I can see that 7.5 compose already has this in main variants
 
lkocman@rcm-dev:utility-scripts> locate-rhel7-rpms-history gnome-shell-extension-top-icons
7.2 Client-optional/x86_64/os/Packages/gnome-shell-extension-top-icons-3.14.4-13.el7.noarch.rpm
7.2 Server-optional/aarch64/os/Packages/gnome-shell-extension-top-icons-3.14.4-13.el7.noarch.rpm
7.2 Server-optional/ppc64/os/Packages/gnome-shell-extension-top-icons-3.14.4-13.el7.noarch.rpm
7.2 Server-optional/ppc64le/os/Packages/gnome-shell-extension-top-icons-3.14.4-13.el7.noarch.rpm
7.2 Server-optional/s390x/os/Packages/gnome-shell-extension-top-icons-3.14.4-13.el7.noarch.rpm
7.2 Server-optional/x86_64/os/Packages/gnome-shell-extension-top-icons-3.14.4-13.el7.noarch.rpm
7.2 Workstation-optional/x86_64/os/Packages/gnome-shell-extension-top-icons-3.14.4-13.el7.noarch.rpm
7.3 Client-optional/x86_64/os/Packages/gnome-shell-extension-top-icons-3.14.4-21.el7.noarch.rpm
7.3 Container-optional/x86_64/os/Packages/gnome-shell-extension-top-icons-3.14.4-21.el7.noarch.rpm
7.3 Server-optional/aarch64/os/Packages/gnome-shell-extension-top-icons-3.14.4-21.el7.noarch.rpm
7.3 Server-optional/ppc64/os/Packages/gnome-shell-extension-top-icons-3.14.4-21.el7.noarch.rpm
7.3 Server-optional/ppc64le/os/Packages/gnome-shell-extension-top-icons-3.14.4-21.el7.noarch.rpm
7.3 Server-optional/s390x/os/Packages/gnome-shell-extension-top-icons-3.14.4-21.el7.noarch.rpm
7.3 Server-optional/x86_64/os/Packages/gnome-shell-extension-top-icons-3.14.4-21.el7.noarch.rpm
7.3 Workstation-optional/x86_64/os/Packages/gnome-shell-extension-top-icons-3.14.4-21.el7.noarch.rpm
7.4 Client-optional/x86_64/os/Packages/gnome-shell-extension-top-icons-3.22.2-10.el7.noarch.rpm
7.4 Server-optional/aarch64/os/Packages/gnome-shell-extension-top-icons-3.22.2-10.el7.noarch.rpm
7.4 Server-optional/ppc64/os/Packages/gnome-shell-extension-top-icons-3.22.2-10.el7.noarch.rpm
7.4 Server-optional/ppc64le/os/Packages/gnome-shell-extension-top-icons-3.22.2-10.el7.noarch.rpm
7.4 Server-optional/s390x/os/Packages/gnome-shell-extension-top-icons-3.22.2-10.el7.noarch.rpm
7.4 Server-optional/x86_64/os/Packages/gnome-shell-extension-top-icons-3.22.2-10.el7.noarch.rpm
7.4 Workstation-optional/x86_64/os/Packages/gnome-shell-extension-top-icons-3.22.2-10.el7.noarch.rpm
7.5 Client/x86_64/os/Packages/gnome-shell-extension-top-icons-3.26.2-3.el7.noarch.rpm
7.5 Server/ppc64/os/Packages/gnome-shell-extension-top-icons-3.26.2-3.el7.noarch.rpm
7.5 Server/ppc64le/os/Packages/gnome-shell-extension-top-icons-3.26.2-3.el7.noarch.rpm
7.5 Server/s390x/os/Packages/gnome-shell-extension-top-icons-3.26.2-3.el7.noarch.rpm
7.5 Server/x86_64/os/Packages/gnome-shell-extension-top-icons-3.26.2-3.el7.noarch.rpm
7.5 Workstation/x86_64/os/Packages/gnome-shell-extension-top-icons-3.26.2-3.el7.noarch.rpm
lkocman@rcm-dev:utility-scripts> 

Package is not just in optional repository since 7.5 GA is was really pushed to main repos as well. Particulary checked server.x86_64 has it.


lkocman@rcm-dev:utility-scripts> rhsm-pulp-manager-v2 --list-packages-in-repo --repo rhel-7-server-rpms__7Server__x86_64 --prod | grep gnome-shell-extension-top-icons
fd431d51 gnome-shell-extension-top-icons-3.26.2-3.el7.noarch.rpm


lkocman@rcm-dev:utility-scripts> /mnt/redhat/scripts/rel-eng/utility/rhn/rhn-info --server prod --packages-simple --channel rhel-x86_64-server-7 --user $USER --password $PASSWORD  | grep gnome-shell-extension-top-icons
gnome-shell-extension-top-icons-3.26.2-3.el7.noarch.rpm
lkocman@rcm-dev:utility-scripts> 


I'll need full repo list that's used during update and output from yum update. Otehrwise it sounds like "works for me".

Comment 21 masanari iida 2018-05-14 09:54:04 UTC
# rpm -qa |grep dmid
python-dmidecode-3.12.2-1.el7.x86_64
dmidecode-3.1-2.el7.x86_64
#
# dmidecode |more
# dmidecode 3.1
Getting SMBIOS data from sysfs.
SMBIOS 3.1.1 present.
Table at 0x89622000.


# dmidecode -t 1
# dmidecode 3.1
Getting SMBIOS data from sysfs.
SMBIOS 3.1.1 present.

Handle 0x005F, DMI type 1, 27 bytes
System Information
        Manufacturer: HPE
        Product Name: ProLiant BL460c Gen10
        Version: Not Specified
        Serial Number: 2Mxxxxxxx
        UUID: 34333638-3234-4d32-3237-333330353530
        Wake-up Type: Power Switch
        SKU Number: 863442-B21
        Family: ProLiant

Test on BL460c Gen10 with SMBIOS 3.1.1,  
the dmidecode output expected result.

Comment 23 Keigo Noha 2018-05-15 00:19:29 UTC
Hello Iida-san,

It seems that you posted your update to the different bugzilla.
Could you post your update to the correct bugzilla?

Best Regards,
Keigo Noha

Comment 25 Lubos Kocman 2018-05-16 14:33:40 UTC
I had initial thought that issue was reported against Server


Workstation has it truly only in optional

lkocman@rcm-dev:~> rhsm-pulp-manager-v2 --prod --repo rhel-7-workstation-rpms__7Workstation__x86_64 --list-packages-in-repo | grep gnome-shell-extension-top-icons
lkocman@rcm-dev:~> rhsm-pulp-manager-v2 --prod --repo rhel-7-workstation-optional-rpms__7Workstation__x86_64 --list-packages-in-repo | grep gnome-shell-extension-top-icons
fd431d51 gnome-shell-extension-top-icons-3.26.2-3.el7.noarch.rpm
fd431d51 gnome-shell-extension-top-icons-3.22.2-10.el7.noarch.rpm
fd431d51 gnome-shell-extension-top-icons-3.14.4-21.el7.noarch.rpm
fd431d51 gnome-shell-extension-top-icons-3.14.4-13.el7.noarch.rpm
lkocman@rcm-dev:~> 

Which is expected according to history.

lkocman@rcm-dev:~> locate-rhel7-rpms-history gnome-shell-extension-top-icons | grep Workstation 
7.2 Workstation-optional/x86_64/os/Packages/gnome-shell-extension-top-icons-3.14.4-13.el7.noarch.rpm
7.3 Workstation-optional/x86_64/os/Packages/gnome-shell-extension-top-icons-3.14.4-21.el7.noarch.rpm
7.4 Workstation-optional/x86_64/os/Packages/gnome-shell-extension-top-icons-3.22.2-10.el7.noarch.rpm
7.5 Workstation/x86_64/os/Packages/gnome-shell-extension-top-icons-3.26.2-3.el7.noarch.rpm
lkocman@rcm-dev:~> 

lkocman@rcm-dev:~> repoquery --repofrompath ws,/mnt/redhat/released/RHEL-7/7.5/Workstation/x86_64/os --repoid ws --whatrequires gnome-shell-extension-top-icons
gnome-classic-session-0:3.26.2-3.el7.noarch

This seems to be different from 7.4

lkocman@rcm-dev:~> repoquery --repofrompath ws,/mnt/redhat/released/RHEL-7/7.4/Workstation/x86_64/os --repoid ws --whatrequires gnome-shell-extension-top-icons
lkocman@rcm-dev:~> 

My expectation is that builds in gnome advisory were not reloaded after this dependency was introduced.

The same is suggested ET which claims filelist mistmatch. https://errata.devel.redhat.com/release_engineering/product_listings?rp%5Bnvr%5D=gnome-shell-extensions-3.26.2-3.el7&rp%5Brelease_version_id%5D=713

Reloading advisory to fix the issue

Comment 26 Tomas Pelka 2018-05-18 08:15:27 UTC
OK so particular erratum was repushed and ready to be tested by RTT.

Comment 27 Lubos Kocman 2018-05-18 09:46:04 UTC
Pushed live (Friday exception was communicated)

http://pub.devel.redhat.com/pub/task/162337 RHN
http://pub.devel.redhat.com/pub/task/162338 CDN


Note You need to log in before you can comment on or make changes to this bug.