Bug 1566877 - Repetitive Storage Managers
Summary: Repetitive Storage Managers
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.9.3
Assignee: Marek Aufart
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 06:35 UTC by Nikhil Dhandre
Modified: 2018-04-18 06:50 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-18 06:50:17 UTC
Category: ---
Cloudforms Team: Openstack
Target Upstream Version:


Attachments (Terms of Use)
Block Manager (deleted)
2018-04-13 06:35 UTC, Nikhil Dhandre
no flags Details

Description Nikhil Dhandre 2018-04-13 06:35:57 UTC
Description of problem:
-----------------------
repetitive storage managers in UI

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
Version 5.9.2.2.20180410215257_6961422


How reproducible:
-----------------
100%

Steps to Reproduce:
1. Navigate to Storage Manager Block or Object

Actual results:
---------------
two storage managers display one with cap and other with the small provider name.
like:
1. rhos11 Swift Manager
2. RHOS11 Swift Manager

Expected results:
-----------------
It should not


Additional info:
----------------
Attaching screenshots

Comment 6 Marek Aufart 2018-04-13 14:21:30 UTC
The situation is that each OpenStack Cloud provider has its Storage Manager. There are two providers, so there also 2 Storage Managers (RHOS 11 and rhos 11).

Currently RHOS 11 and rhos 11 Providers point to the same endpoint, but using different Keystone versions (2 vs. 3 with domain) and that makes possible to add them as different providers. On the OSP side "default" domain with keystone v3 is the same as keystone v2 (no domains are supported), but there can be more conmplicated setups of OpenStack..

So even I understand that this might look as misleading, it is not a bug and we should not be restricting uniqueness requirements on OSP Cloud providers.

Comment 7 Marek Aufart 2018-04-17 12:01:58 UTC
Based on Comment #6 (there are two providers and for each storage manager exists which is ok), this looks to me as not a bug, can we close it?

Comment 8 Nikhil Dhandre 2018-04-17 18:06:14 UTC
Hi Marek,

Yes, you can close this bug. As its possible to add the same provider with different keystone version.


Note You need to log in before you can comment on or make changes to this bug.