Bug 1566948 - Preview of snapshot with memory crashes on missing `serial' attribute
Summary: Preview of snapshot with memory crashes on missing `serial' attribute
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: vdsm
Classification: oVirt
Component: Core
Version: 4.20.23
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.2.3
: ---
Assignee: Francesco Romani
QA Contact: Vitalii Yerys
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 08:20 UTC by Milan Zamazal
Modified: 2018-05-10 06:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 06:30:20 UTC
oVirt Team: Virt
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 89384 None None None 2018-04-13 08:25:34 UTC
oVirt gerrit 89883 ovirt-4.2 MERGED virt: snap preview: look by serial, then for alias 2018-04-17 08:22:34 UTC
oVirt gerrit 89884 ovirt-4.2 MERGED virt: snap preview: amend data only for disks 2018-04-16 17:17:49 UTC

Description Milan Zamazal 2018-04-13 08:20:02 UTC
Description of problem:

When I run preview of snapshot with memory in basic-suite-4.2 oVirt system test posted at https://gerrit.ovirt.org/#/c/86571/4, the VM fails to start with the following error:

  Traceback (most recent call last):
    File "/usr/lib/python2.7/site-packages/vdsm/API.py", line 225, in create
      return self._cif.createVm(vmParams)
    File "/usr/lib/python2.7/site-packages/vdsm/clientIF.py", line 558, in createVm
      vm = Vm(self, vmParams, vmRecover)
    File "/usr/lib/python2.7/site-packages/vdsm/virt/vm.py", line 360, in __init__
      self._src_domain_xml, params['xml'])
    File "/usr/lib/python2.7/site-packages/vdsm/virt/vm.py", line 2937, in _correct_disk_volumes_from_xml
      change_disk(element, devices, self.log)
    File "/usr/lib/python2.7/site-packages/vdsm/virt/vmdevices/storagexml.py", line 260, in change_disk
      serial = vmxml.text(vmxml.find_first(disk_element, 'serial'))
    File "/usr/lib/python2.7/site-packages/vdsm/virt/vmxml.py", line 112, in find_first
      raise NotFound((element, tag,))
  NotFound: (<Element 'disk' at 0x7f64a418a990>, 'serial')

Version-Release number of selected component (if applicable):

Current Vdsm from ovirt-4.2 branch.

How reproducible:

100%

Steps to Reproduce:

Run the OST from gerrit URL given above on basic-suite-4.2 with current Vdsm ovirt-4.2 branch.

Actual results:

The VM fails to start.

Expected results:

The VM starts from the given snapshot.

Comment 1 Milan Zamazal 2018-04-25 08:01:04 UTC
As for verification, I suggest creating a VM with a CD-ROM and a LUN device, making a snapshot of it and then to preview the snapshot.

Comment 2 Vitalii Yerys 2018-04-26 11:02:21 UTC
Verified with vdsm-4.20.26-1.el7ev.x86_64

Comment 3 Sandro Bonazzola 2018-05-10 06:30:20 UTC
This bugzilla is included in oVirt 4.2.3 release, published on May 4th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.