Bug 1566987 - Can't auto trigger build when push code to git server repo
Summary: Can't auto trigger build when push code to git server repo
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: ImageStreams
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Ben Parees
QA Contact: Dongbo Yan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 09:24 UTC by XiuJuan Wang
Modified: 2018-04-16 11:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-16 11:56:30 UTC
Target Upstream Version:
xiuwang: needinfo-


Attachments (Terms of Use)

Description XiuJuan Wang 2018-04-13 09:24:11 UTC
Description of problem:
Can't auto trigger build when push code to git server repo due to 
no kind \"PodProxyOptions\" is registered for version \"build.openshift.io/v1\""

Only reproduced in 3.6 cluster env

Version-Release number of selected component (if applicable):

oc v3.6.173.0.96
kubernetes v1.6.1+5115d708d7
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://**:8443
openshift v3.6.173.0.96
kubernetes v1.6.1+5115d708d7

docker.io/openshift/origin-gitserver:latest(c788ff7985e7)

How reproducible:
always

Steps to Reproduce:
1.Follow https://github.com/openshift/origin/tree/master/examples/gitserver#deploy-the-git-server to deploy a git server pod
2.Init code to git server repo
3.Change some thing in git server repo, then push back

Actual results:
step 3:
 $git push origin master
Username for 'http://git-1cp65.apps.0412-wz9.qe.rhcloud.com': xiuwang 
Password for 'http://xiuwang@git-1cp65.apps.0412-wz9.qe.rhcloud.com': 
Counting objects: 7, done.
Delta compression using up to 8 threads.
Compressing objects: 100% (6/6), done.
Writing objects: 100% (6/6), 588 bytes | 0 bytes/s, done.
Total 6 (delta 3), reused 0 (delta 0)
remote: error: server rejected our request 500
remote: remote: {"kind":"Status","apiVersion":"v1","metadata":{},"status":"Failure","message":"no kind \"PodProxyOptions\" is registered for version \"build.openshift.io/v1\"","code":500}
To http://git-1cp65.apps.0412-wz9.qe.rhcloud.com/ruby-hello-world


Expected results:
Could auto trigger build

Additional info:
All versions 3.6-3.9 use build.openshift.io/v1 for builds.

  ownerReferences:
  - apiVersion: build.openshift.io/v1

Comment 1 Ben Parees 2018-04-16 01:47:02 UTC
Are you saying it works in v3.7+?  If so I'm going to close this as won't fix since the gitserver is a fairly unsupported example that we aren't going to invest in fixing on older levels.

Comment 2 XiuJuan Wang 2018-04-16 03:30:26 UTC
Yes, works in 3.7+ cluster.
The gitserver is unsupported for all ocp version, or just unsupported below 3.7?

Comment 3 Ben Parees 2018-04-16 11:56:30 UTC
unsupported for all/any version.  it's always been an unsupported example.


Note You need to log in before you can comment on or make changes to this bug.