Bug 15670 - Upgrade fails detecting previous install due to reiserfs or Beos partitions
Upgrade fails detecting previous install due to reiserfs or Beos partitions
Status: CLOSED DUPLICATE of bug 27610
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-07 14:37 EDT by Miles Lott
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-04 16:11:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miles Lott 2000-08-07 14:37:25 EDT
The RH 6.2 install's root fs is /dev/hdc4.  When attempting to upgrade, the
installer finds
reiserfs and BeOS partitions on that drive.  /dev/hdc4 is ext2 formatted. 
The installer presents
an error message for each 'invalid' partition.  Then the installer presents
a critical message
that I need to reboot the old install and run fsck on the partitions it
finds:

   Device Boot    Start       End    Blocks   Id  System
/dev/hdc1             2       256   2048287+  eb  BeOS fs
/dev/hdc2           257       513   2064352+  83  Linux	<---reiserfs
/dev/hdc3           514       770   2064352+  83  Linux	<---reiserfs
/dev/hdc4   *       771      1027   2064352+  83  Linux	<---ext2

In any event, these partitions are ok and do not need to be fscked.  The
installer will not
continue.
Comment 1 Erik Troan 2000-08-08 12:29:08 EDT
Comment them out of the fstab on the ext2 partition. This is a hack, and we'll
get around to fixing it when we add proper support for reiserfs.
Comment 2 Miles Lott 2000-08-10 20:05:40 EDT
That hack did not work, as the install process is detecting the partitions on
the drives,
not reading fstab (at least at the point of failure).
Comment 3 Erik Troan 2000-08-11 10:56:02 EDT
Change the partition types as well then. Solving this properly is too much work
for this late in the process.
Comment 4 Miles Lott 2001-04-22 00:40:49 EDT
Pardon me, but this is definitely a bug.  It was a bug when it was closed during
the Lorax beta,
and it continues to be a problem today with RH 7.1.

How dare you close this with such a blatant 'kiss off message'?
Is it STILL too late to fix this?  Like it or not reiserfs is a reality.

I don't suppose you give a crap that I have been a loyal Redhat
user since 4.1?  I don't blame you for that.  But ignoring stupid
little problems like this are what make you become an inhuman
monolith like those other guys.  Watch out, because you will
get buried with this attitude!
Comment 5 Brent Fox 2001-05-04 16:11:49 EDT

*** This bug has been marked as a duplicate of 27610 ***

Note You need to log in before you can comment on or make changes to this bug.