Bug 1567004 - secret of servicebinding in project openshift-ansible-service-broker should be removed after unbind
Summary: secret of servicebinding in project openshift-ansible-service-broker should b...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Derek Whatley
QA Contact: Zihan Tang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 09:42 UTC by Zhang Cheng
Modified: 2018-07-30 19:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:12:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:13:33 UTC

Description Zhang Cheng 2018-04-13 09:42:27 UTC
Description of problem: 
secret of servicebinding in project openshift-ansible-service-broker should be removed after unbind


service-catalog & asb image using images from downstream registry:
# service-catalog --version
v3.10.0-0.21.0;Upstream:v0.1.13

# asbd --version
1.2.5


How reproducible:
Always


Steps to Reproduce:
1. Provision a postgreSQL serviceinstance from web console.
2. Create a servicebinding from web console.
3. Check relate secret of servicebinding in openshift-ansible-service-broker project
4. Delete the servicebinding from web console
5. Check relate secret of servicebinding in openshift-ansible-service-broker project again


Actual results:  
5. The secret of servicebinding still exist in openshift-ansible-service-broker project
# oc get secrets 01c6312f-3efb-11e8-aaac-0a580a81000a -o yaml
apiVersion: v1
data:
  credentials: eyJEQl9IT1NUIjoicG9zdGdyZXNxbCIsIkRCX05BTUUiOiJhZG1pbiIsIkRCX1BBU1NXT1JEIjoidGVzdCIsIkRCX1BPUlQiOiI1NDMyIiwiREJfVFlQRSI6InBvc3RncmVzIiwiREJfVVNFUiI6ImFkbWluIn0=
kind: Secret
metadata:
  creationTimestamp: 2018-04-13T09:14:02Z
  name: 01c6312f-3efb-11e8-aaac-0a580a81000a
  namespace: openshift-ansible-service-broker
  resourceVersion: "24921"
  selfLink: /api/v1/namespaces/openshift-ansible-service-broker/secrets/01c6312f-3efb-11e8-aaac-0a580a81000a
  uid: 02075eb8-3efb-11e8-8bc9-fa163ef8f270
type: Opaque


Expected results: 
5. The secret of servicebinding should be cleaned up.


Addition info: 
None

Comment 1 Derek Whatley 2018-04-19 18:21:08 UTC
Posted PR fix: https://github.com/openshift/ansible-service-broker/pull/899

Comment 2 Derek Whatley 2018-04-24 13:41:53 UTC
PR has been merged.

Comment 3 Zihan Tang 2018-04-26 02:59:29 UTC
verified.
asb version : 1.2.7
scenario: 
In synchronous bind and unbind, when unbind, the extracted credentials secret in openshift-ansible-service-broker will be deleted.

Comment 5 errata-xmlrpc 2018-07-30 19:12:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.