Bug 1567029 - Live Storage Migration fail in VmReplicateDiskFinish phase
Summary: Live Storage Migration fail in VmReplicateDiskFinish phase
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-4.2.4
: ---
Assignee: Benny Zlotnik
QA Contact: Elad
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 10:08 UTC by Pawan kumar Vilayatkar
Modified: 2019-05-16 13:06 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-17 08:44:41 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)

Description Pawan kumar Vilayatkar 2018-04-13 10:08:27 UTC
Description of problem:

Live Storage Migration fail in VmReplicateDiskFinish phase with error message "Failed in vdscommand to VmReplicateDiskFinishVDS, error = Failed to change disk image" 

On the vdsm side the error message observed was "Unable to stop the replication for the drive" 



Version-Release number of selected component (if applicable):

rhevm-4.1.9.2-0.1.el7.noarch
vdsm-4.19.31-1.el7ev.x86_64

Comment 16 Gianluca Cecchi 2018-05-17 07:06:14 UTC
I confirm that I was able to reproduce the same problem in a new self hosted engine environment based on iSCSI storage domain.
Initial config:
2 hosts based on RHVH-4.1-20171002.1-RHVH-x86_64-dvd1.iso

after installation

OS Version: RHEL - 7.4 - 6.0.el7 
OS Description: Red Hat Virtualization Host 4.1 (el7.4) 
Kernel Version: 3.10.0 - 693.2.2.el7.x86_64 
KVM Version: 2.9.0 - 16.el7_4.5 
LIBVIRT Version: libvirt-3.2.0-14.el7_4.3 
VDSM Version: vdsm-4.19.31-1.el7ev 
SPICE Version: 0.12.8 - 2.el7.1 
GlusterFS Version: glusterfs-3.8.4-18.6.el7rhgs 
CEPH Version: librbd1-0.94.5-2.el7 
Kernel Features: N/A


Engine at level 4.1.11.2-0.1.el7 (the original env where initially got the problem was with engine in version 4.1.9.2-0.1.el7)

after updating hosts, live storage migration always completes without errors. Versions of the OK updated environment:


OS Version: RHEL - 7.5-0.14 - 11.0.el7 
OS Description: Red Hat Virtualization Host 4.1 (el7.5-0.14) 
Kernel Version: 3.10.0 - 862.el7.x86_64 
KVM Version: 2.10.0 - 21.el7_5.1 
LIBVIRT Version: libvirt-3.9.0-14.el7_5.2 
VDSM Version: vdsm-4.19.51-1.el7ev 
SPICE Version: 0.14.0 - 2.el7 
GlusterFS Version: glusterfs-3.8.4-54.8.el7rhgs 
CEPH Version: librbd1-0.94.5-2.el7 
Kernel Features: IBRS: 0, PTI: 1, IBPB: 0

[root@rhevora3 ~]# cat /proc/cmdline 
BOOT_IMAGE=/rhvh-4.1-0.20180425.0+1/vmlinuz-3.10.0-862.el7.x86_64 root=/dev/rhvh/rhvh-4.1-0.20180425.0+1 ro rd.lvm.lv=rhvh/rhvh-4.1-0.20180425.0+1 rd.lvm.lv=rhvh/swap LANG=en_US.UTF-8 img.bootid=rhvh-4.1-0.20180425.0+1 transparent_hugepage=never
[root@rhevora3 ~]#

Comment 18 Franta Kust 2019-05-16 13:06:25 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.