Bug 1567108 - Catalog Item with Tag Control element cannot be ordered
Summary: Catalog Item with Tag Control element cannot be ordered
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: eclarizi
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks: 1568091
TreeView+ depends on / blocked
 
Reported: 2018-04-13 12:39 UTC by Jan Zmeskal
Modified: 2019-02-11 13:59 UTC (History)
6 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1568091 (view as bug list)
Environment:
Last Closed: 2019-02-11 13:59:16 UTC
Category: ---
Cloudforms Team: RHEVM
Target Upstream Version:


Attachments (Terms of Use)
Submit button cannot be clicked (13.64 KB, image/png)
2018-04-13 12:39 UTC, Jan Zmeskal
no flags Details

Description Jan Zmeskal 2018-04-13 12:39:35 UTC
Created attachment 1421361 [details]
Submit button cannot be clicked

Description of problem:
When you try to submit your order of Catalog Item and that Catalog Item uses Tag Control element in it's dialog, the Submit button is not clickable (see the attached screenshot). It seems that it happens only if Single Value and Required switches are on for the element.

Version-Release number of selected component (if applicable):
5.9.2.2

How reproducible:
100 %

Steps to Reproduce:
1. Create a Service Dialog (Automation -> Automate -> Customization -> Service Dialogs -> Configuration -> Add a New Dialog)
2. It is sufficient to use the default tab and default section. Drag Tag Control element to already existing section and drop it there.
3. Edit your Tag Control Element. In Options choose some Category with multiple options, for example Service Level or Workload. Also make sure that Required, Single Value and Visible switches are on. Save the changes to the element. Save the Dialog.
4. Go to Services -> Catalogs -> Catalogs and create a new Catalog. 
5. Create a new Catalog Item that will be visible in your catalog and will use previously created Service Dialog as its dialog.
6. Go to Services -> Catalogs -> Service Catalogs -> <your_catalog> -> <your_catalog_item> and click Order.
7. Submit button is greyed out because you still have to provide some required values. Click the dropdown menu in your Tag Control element and choose one of the values. 

Actual results:
Submit button is still greyed out and cannot be clicked.

Expected results:
Submit button should activate since all the required information was provided.

Additional info:

Comment 3 Greg McCullough 2018-04-13 12:59:48 UTC
Please review.  Maybe someone else can work on this issue if you can help narrow down the cause.

Comment 5 CFME Bot 2018-04-16 15:24:39 UTC
New commit detected on ManageIQ/ui-components/master:

https://github.com/ManageIQ/ui-components/commit/4c9b2ac9f8622d505b58d4a323a01256a27d40b9
commit 4c9b2ac9f8622d505b58d4a323a01256a27d40b9
Author:     Erik Clarizio <eclarizio@gmail.com>
AuthorDate: Fri Apr 13 12:59:42 2018 -0400
Commit:     Erik Clarizio <eclarizio@gmail.com>
CommitDate: Fri Apr 13 12:59:42 2018 -0400

    Adjust logic for validating DialogFieldTagControl

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1567108

 src/dialog-user/services/dialogData.spec.ts | 136 +
 src/dialog-user/services/dialogData.ts | 32 +
 2 files changed, 168 insertions(+)

Comment 7 Radim Hrazdil 2018-06-26 08:36:23 UTC
Verified following the provided test flow in the description that once the requirements are met, the Submit button is activated and order can be placed.

Version 5.10.0.0.20180613200131_887cc81


Note You need to log in before you can comment on or make changes to this bug.