Bug 1567217 - virtio-drivers on guest-tools iso are older than drivers from virtio-win iso
Summary: virtio-drivers on guest-tools iso are older than drivers from virtio-win iso
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-guest-tools
Version: 4.2.2
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.2.3
: ---
Assignee: Lev Veyde
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks: 1568357
TreeView+ depends on / blocked
 
Reported: 2018-04-13 15:09 UTC by Petr Matyáš
Modified: 2019-05-16 13:06 UTC (History)
3 users (show)

Fixed In Version: rhv-guest-tools-iso-4.2-5
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-05-15 17:56:23 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1568357 0 medium CLOSED handle VFD uploads to the ISO domain 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHEA-2018:1517 0 None None None 2018-05-15 17:57:07 UTC

Internal Links: 1568357

Description Petr Matyáš 2018-04-13 15:09:19 UTC
Description of problem:
Virtio drivers were updated in latest virtio-win iso, they should also be updated in guest-tools iso.

Version-Release number of selected component (if applicable):
rhv-guest-tools-iso-4.2-4.el7ev.noarch
virtio-win-1.9.4-2.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. check version of virtio drivers on guest-tools iso and on virtio-win iso
2.
3.

Actual results:
guest-tools iso contains old virtio drivers

Expected results:
guest-tools iso uses the same (or newer) version of drivers than virtio-win iso

Additional info:

Comment 2 Sandro Bonazzola 2018-04-17 10:45:37 UTC
It will be a bit trickier though than simple rebuild since its:

a) replaces the old Qemu-GA with a new Ming-Qemu-GA
b) have split .VFD images

It means in order to really sync we'll have to send/merge additional patches.

Also we'll need one for the ovirt-engine to handle proper VFD uploads to the ISO domain, tracking it in a separate bug.

Comment 4 Petr Matyáš 2018-04-20 12:07:50 UTC
Verified on RHV-toolsSetup_4.2_5.iso

Versions of all drivers is the same (or higher) as used on virtio-win-1.9.4.iso

Comment 7 errata-xmlrpc 2018-05-15 17:56:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1517

Comment 8 Franta Kust 2019-05-16 13:06:48 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.