Bug 1567350 - Request ability to separate OCP related logs from project containter logs
Summary: Request ability to separate OCP related logs from project containter logs
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jeff Cantrill
QA Contact: Xiaoli Tian
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 20:40 UTC by Greg Rodriguez II
Modified: 2019-06-12 11:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-12 11:57:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Greg Rodriguez II 2018-04-13 20:40:24 UTC
Description of problem:
Customer requesting ability to separate OCP related logs from project containter logs.

example:
openshift node related logs, and node system logs would be known as 'ops' logs.
and
logs from pods within projects, which have only the log output from containers, would be known as 'apps' logs.

Version-Release number of selected component (if applicable):
OCP 3.7

How reproducible:
Customer verified, custom configuration needed but unsupported

Comment 1 Aaren 2018-04-13 20:50:19 UTC
adding comment for tracking purposes, and comments later.

Comment 2 Aaren 2018-04-13 20:51:25 UTC
additonally, requesting to have this backported to OCP 3.6, and ported forward to later versions of OCP (3.9, etc).

Comment 3 Aaren 2018-07-20 14:38:29 UTC
(nudge for visibility.)

Comment 5 Jeff Cantrill 2018-07-23 22:46:55 UTC
I don't really understand the ask here.  Application logs are already separated from node logs.  This has been the case since the inception of the logging stack.

Comment 6 Aaren 2018-07-24 00:24:10 UTC
(In reply to Jeff Cantrill from comment #5)
> I don't really understand the ask here.  Application logs are already
> separated from node logs.  This has been the case since the inception of the
> logging stack.

The objective is to send logs to an external logging stack, such as an external ELK or EFK stack, where we would like to have ops logs and app logs notably marked or seperated. Even as much as to send ops logs to, for example: a external ELK/EFK stack A and apps logs to ELK/EFK stack B.

Also, in cases where multiple OCP clusters exist, and one external ELK/EFK is to ingest all clusters' ops logs and another external ELK/EFK is to ingest all clusters apps logs. 

Numerous customer cases/requests like this have come up.

Comment 10 Kirsten Newcomer 2019-06-12 11:57:00 UTC
With the introduction of OpenShift 4, Red Hat has delivered or roadmapped a substantial number of features based on feedback by our customers.  Many of the enhancements encompass specific RFEs which have been requested, or deliver a comparable solution to a customer problem, rendering an RFE redundant.

This bz (RFE) has been identified as a feature request not yet planned or scheduled for an OpenShift release and is being closed. 

If this feature is still an active request that needs to be tracked, Red Hat Support can assist in filing a request in the new JIRA RFE system, as well as provide you with updates as the RFE progress within our planning processes. Please open a new support case: https://access.redhat.com/support/cases/#/case/new 

Opening a New Support Case: https://access.redhat.com/support/cases/#/case/new 

As the new Jira RFE system is not yet public, Red Hat Support can help answer your questions about your RFEs via the same support case system.


Note You need to log in before you can comment on or make changes to this bug.