Bug 1567368 - CinderNetappNfsMountOptions missing from puppet manifest
Summary: CinderNetappNfsMountOptions missing from puppet manifest
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z9
: 10.0 (Newton)
Assignee: Alan Bishop
QA Contact: Avi Avraham
Kim Nylander
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 21:08 UTC by Chris Paquin
Modified: 2018-09-17 16:55 UTC (History)
10 users (show)

Fixed In Version: puppet-tripleo-5.6.8-8.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the CinderNetappNfsMountOptions TripleO Heat parameter was inadvertently ignored, and was not used to configure the corresponding setting in the Cinder Netapp backend. As a result, it was not possible to configure the Netapp NFS mount options with the TripleO Heat parameter. With this update, the code responsible for handling the Cinder Netapp configuration no longer ignores the CinderNetappNfsMountOptions parameter and the CinderNetappNfsMountOptions parameter correctly configures the Cinder Netapp NFS mount options.
Clone Of:
: 1590952 (view as bug list)
Environment:
Last Closed: 2018-09-17 16:54:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1773013 0 None None None 2018-05-23 20:42:08 UTC
OpenStack gerrit 570256 0 None MERGED Add missing nfs_mount_options for Cinder Netapp backend 2021-02-17 11:11:21 UTC
Red Hat Product Errata RHBA-2018:2670 0 None None None 2018-09-17 16:55:29 UTC

Description Chris Paquin 2018-04-13 21:08:19 UTC
Description of problem:

cinder-netapp.yaml has a parameter for nfs mount options

CinderNetappNfsMountOptions 

This param is referenced in /usr/share/openstack-tripleo-heat-templates/puppet/extraconfig/pre_deploy/controller/cinder-netapp.yaml

The specific line is below. 

cinder::backend::netapp::nfs_mount_options: {get_input: NetappNfsMountOptions}

However, the puppet template , /etc/puppet/modules/tripleo/manifests/profile/base/cinder/volume/netapp.pp
does not include NFS mount options, inline with the other values such as  what is shown below.

cinder::backend::netapp { $backend_name :
      netapp_login                 => hiera('cinder::backend::netapp::netapp_login', undef),
      netapp_password              => hiera('cinder::backend::netapp::netapp_password', undef),
      netapp_server_hostname       => hiera('cinder::backend::netapp::netapp_server_hostname', undef),
      netapp_server_port           => hiera('cinder::backend::netapp::netapp_server_port', undef),
      netapp_size_multiplier       => hiera('cinder::backend::netapp::netapp_size_multiplier', undef),
      netapp_storage_family        => hiera('cinder::backend::netapp::netapp_storage_family', undef),
      netapp_storage_protocol      => hiera('cinder::backend::netapp::netapp_storage_protocol', undef),
      netapp_transport_type        => hiera('cinder::backend::netapp::netapp_transport_type', undef),
      netapp_vfiler                => hiera('cinder::backend::netapp::netapp_vfiler', undef),
      netapp_volume_list           => hiera('cinder::backend::netapp::netapp_volume_list', undef),
      netapp_vserver               => hiera('cinder::backend::netapp::netapp_vserver', undef),
      netapp_partner_backend_name  => hiera('cinder::backend::netapp::netapp_partner_backend_name', undef),
      nfs_shares                   => $cinder_netapp_nfs_shares,
      nfs_shares_config            => hiera('cinder::backend::netapp::nfs_shares_config', undef),
      netapp_copyoffload_tool_path => hiera('cinder::backend::netapp::netapp_copyoffload_tool_path', undef),
      netapp_controller_ips        => hiera('cinder::backend::netapp::netapp_controller_ips', undef),
      netapp_sa_password           => hiera('cinder::backend::netapp::netapp_sa_password', undef),
      netapp_storage_pools         => hiera('cinder::backend::netapp::netapp_storage_pools', undef),
      netapp_eseries_host_type     => hiera('cinder::backend::netapp::netapp_eseries_host_type', undef),
      netapp_webservice_path       => hiera('cinder::backend::netapp::netapp_webservice_path', undef),
    }
  }



How reproducible:
Deploy cinder netapp backend, attempt to set nfs mount options using override in a template, deploy completes however, no value for CinderNetappNfsMountOptions is not set.

Comment 1 Alan Bishop 2018-04-24 14:28:00 UTC
Indeed, a couple of parameters are missing in the puppet-tripleo binding between THT and puppet-cinder. In puppet-cinder the netapp backend is implemented as a 'define' and so hiera bindings don't work.

I also noticed puppet-tripleo isn't handling the CinderNetappHostType parameter.

Comment 2 Alan Bishop 2018-05-29 12:25:34 UTC
Patch has merged on upstream master, now backporting to upstream stable branches.

Comment 16 errata-xmlrpc 2018-09-17 16:54:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2670


Note You need to log in before you can comment on or make changes to this bug.