Bug 1567370 - Error: Could not find data item manila::backend::netapp::netapp_root_volume_aggregate in any Hiera data file and no default supplied at /etc/puppet/modules/tripleo/manifests/profile/pacemaker/manila.pp:112 on node
Summary: Error: Could not find data item manila::backend::netapp::netapp_root_volume_a...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-manila
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: Upstream M1
: 14.0 (Rocky)
Assignee: Goutham Pacha Ravi
QA Contact: Dustin Schoenbrun
mmurray
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 21:18 UTC by Chris Paquin
Modified: 2018-09-20 23:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-20 23:32:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
openstack-tripleo-heat-templates-5.3.8-1.tar (1.88 MB, application/x-tar)
2018-07-10 14:02 UTC, Chris Paquin
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1779072 0 None None None 2018-06-28 07:59:46 UTC

Description Chris Paquin 2018-04-13 21:18:31 UTC
Description of problem: Attempting to deploy OSP12 with manila, without setting up a volume aggregate which does not seem to be required. When configuring manila manually, this value is not required.

When referencing the puppet manifest list in the error.

/etc/puppet/modules/tripleo/manifests/profile/pacemaker/manila.pp

We can see that all values except for hiera('manila::backend::netapp::driver_handles_share_servers', true) allow an undefined value/string. 

  manila::backend::netapp { $manila_netapp_backend :
        driver_handles_share_servers         => hiera('manila::backend::netapp::driver_handles_share_servers', true),
        netapp_login                         => hiera('manila::backend::netapp::netapp_login'),
        netapp_password                      => hiera('manila::backend::netapp::netapp_password'),
        netapp_server_hostname               => hiera('manila::backend::netapp::netapp_server_hostname'),
        netapp_transport_type                => hiera('manila::backend::netapp::netapp_transport_type'),
        netapp_storage_family                => hiera('manila::backend::netapp::netapp_storage_family'),
        netapp_server_port                   => hiera('manila::backend::netapp::netapp_server_port'),
        netapp_volume_name_template          => hiera('manila::backend::netapp::netapp_volume_name_template'),
        netapp_vserver                       => hiera('manila::backend::netapp::netapp_vserver'),
        netapp_vserver_name_template         => hiera('manila::backend::netapp::netapp_vserver_name_template'),
        netapp_lif_name_template             => hiera('manila::backend::netapp::netapp_lif_name_template'),
        netapp_aggregate_name_search_pattern => hiera('manila::backend::netapp::netapp_aggregate_name_search_pattern'),
        netapp_root_volume_aggregate         => hiera('manila::backend::netapp::netapp_root_volume_aggregate'),
        netapp_root_volume_name              => hiera('manila::backend::netapp::netapp_root_volume'),
        netapp_port_name_search_pattern      => hiera('manila::backend::netapp::netapp_port_name_search_pattern'),
        netapp_trace_flags                   => hiera('manila::backend::netapp::netapp_trace_flags'),


This forces the user to define values that are not required. 

Compare to /etc/puppet/modules/tripleo/manifests/profile/base/cinder/volume/netapp.pp which allows for undefined values/params.

Comment 1 Chris Paquin 2018-04-17 21:26:53 UTC
Correction we were testing with OSP10 not OSP12

Comment 2 Goutham Pacha Ravi 2018-06-28 20:27:20 UTC
Hey Chris, 

I opened a Launchpad bug mirroring this BZ. However, I haven't been able to reproduce this error with OSP 10 or OSP 12. Can you share the log files and/or the templates you used so we can dig in further? Please strip away any private/customer information as appropriate. 

Thanks!

Comment 3 Chris Paquin 2018-07-10 14:02:01 UTC
I am currently seeing this issue in two environments.

One using openstack-tripleo-heat-templates-5.2.0-15.el7ost.noarch, the other, 
openstack-tripleo-heat-templates-5.3.8-1.el7ost.noarch

Attaching tarball of default templates.

Comment 4 Chris Paquin 2018-07-10 14:02:51 UTC
Created attachment 1457838 [details]
openstack-tripleo-heat-templates-5.3.8-1.tar

Comment 5 Alan Bishop 2018-07-10 14:45:29 UTC
This problem seems related to something that was fixed a while ago ([1]).

[1] https://review.openstack.org/444314

I checked openstack-tripleo-heat-templates-5.3.8-1 and see the patch [1] *is* present, which is good. However, it's possible that the env file you're using in the deployment might be undoing what the patch is attempting to resolve.

Please list the deployment command you're running, and attach a copy (scrubbed of any private data) of the env files, particularly the one that has the Netapp settings.

Moving back to ASSIGNED because I believe any additional patches have been proposed.

Comment 6 Chris Paquin 2018-08-31 16:50:45 UTC
I am unable to validate against the OSP 12 env. The customer has removed this test environment and is moving on to test with OSP 12.

Comment 7 Goutham Pacha Ravi 2018-09-20 23:32:19 UTC
Thanks Chris. We believe this issue is fixed. If we're incorrect in thinking so, please reopen this bug.


Note You need to log in before you can comment on or make changes to this bug.