Bug 1567518 - Lenovo Thinkpad Yoga 12 touchpad stops working randomly
Summary: Lenovo Thinkpad Yoga 12 touchpad stops working randomly
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-14 17:15 UTC by Steve
Modified: 2018-10-29 17:41 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-29 17:41:10 UTC
Type: Bug


Attachments (Terms of Use)
log showing the repeated failure of the touchpad (9.47 KB, text/plain)
2018-04-14 17:15 UTC, Steve
no flags Details

Description Steve 2018-04-14 17:15:27 UTC
Created attachment 1421794 [details]
log showing the repeated failure of the touchpad

Description of problem:

After a recent kernel upgrade (about 2 weeks ago?), the touchpad in my Lenovo Thinkpad Yoga 12 stops working at random intervals. It can be reactivated by executing rmmod rmi_smbus and insmod rmi_smbus but that is obvious suboptimal.

The touchpad in this laptop is: Synaptics TM3075


Version-Release number of selected component (if applicable):
kernel version is: 4.15.15-300.fc27.x86_64


How reproducible:


Steps to Reproduce:
1. start a desktop session
2. work for a while (random amount)
3. 

Actual results:

cursor stops responding to touchpad input

Expected results:

touchpad keeps working...

Additional info:
The following messages appear in the journal:
Apr 14 16:39:09 localhost.localdomain kernel: rmi4_physical rmi4-00: Failed to read irqs, code=-6
Apr 14 16:39:09 localhost.localdomain kernel: rmi4_physical rmi4-00: Failed to read irqs, code=-6

at that point the touchpoint stopped working.

Now I execute the rmmod rmi_smbus & insmod rmi_smbus commands to get it working again...


Apr 14 16:39:53 localhost.localdomain kernel: rmi4_smbus 6-002c: registering SMbus-connected sensor
Apr 14 16:39:53 localhost.localdomain kernel: rmi4_f01 rmi4-01.fn01: found RMI device, manufacturer: Synaptics, product: TM3075-002, fw id: 1741313
Apr 14 16:39:53 localhost.localdomain kernel: input: Synaptics TM3075-002 as /devices/rmi4-01/input/input38
Apr 14 16:44:49 localhost.localdomain kernel: rmi4_physical rmi4-01: Failed to read irqs, code=-6
Apr 14 16:46:09 localhost.localdomain kernel: rmi4_smbus 6-002c: registering SMbus-connected sensor
Apr 14 16:46:09 localhost.localdomain kernel: rmi4_f01 rmi4-02.fn01: found RMI device, manufacturer: Synaptics, product: TM3075-002, fw id: 1741313
Apr 14 16:46:09 localhost.localdomain kernel: input: Synaptics TM3075-002 as /devices/rmi4-02/input/input40

stopped working again....

Apr 14 17:01:40 localhost.localdomain kernel: rmi4_physical rmi4-02: Failed to read irqs, code=-6
Apr 14 17:01:41 localhost.localdomain kernel: rmi4_physical rmi4-02: Failed to read irqs, code=-6
Apr 14 17:01:41 localhost.localdomain kernel: rmi4_physical rmi4-02: Failed to read irqs, code=-6
Apr 14 17:01:41 localhost.localdomain kernel: rmi4_physical rmi4-02: Failed to read irqs, code=-6
Apr 14 17:01:41 localhost.localdomain kernel: rmi4_physical rmi4-02: Failed to read irqs, code=-6
Apr 14 17:01:41 localhost.localdomain kernel: rmi4_physical rmi4-02: Failed to read irqs, code=-6
Apr 14 17:01:44 localhost.localdomain kernel: rmi4_physical rmi4-02: Failed to read irqs, code=-6
Apr 14 17:01:44 localhost.localdomain kernel: rmi4_physical rmi4-02: Failed to read irqs, code=-6
Apr 14 17:01:44 localhost.localdomain kernel: rmi4_physical rmi4-02: Failed to read irqs, code=-6
Apr 14 17:02:04 localhost.localdomain kernel: rmi4_smbus 6-002c: registering SMbus-connected sensor

needed to re-execute the rmmod and insmod workaround.

Apr 14 17:02:04 localhost.localdomain kernel: rmi4_f01 rmi4-03.fn01: found RMI device, manufacturer: Synaptics, product: TM3075-002, fw id: 1741313
Apr 14 17:02:05 localhost.localdomain kernel: input: Synaptics TM3075-002 as /devices/rmi4-03/input/input42

has been working since in this session.

This bug is similar to 1485013 but I am affected without having suspended the laptop first.

During this bug report the touchpad failed numerous times (see attached log). Each time I needed to remove and insert the rmi_smbus module to get it working again.

Comment 1 Steve 2018-05-30 19:45:25 UTC
I upgraded to Fedora 28 and the bug still happens.

Comment 2 Steve 2018-06-04 19:10:59 UTC
After some more googling...

Adding 

psmouse.synaptics_intertouch=0

to the kernel start-up parameters seems to have cured the unresponsive touchpad somewhat. However, I know get a very laggy mouse pointer every now and then and the following entries in my log

Jun 03 18:07:16 localhost.localdomain kernel: psmouse serio1: TouchPad at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.
Jun 03 18:07:16 localhost.localdomain kernel: psmouse serio1: resync failed, issuing reconnect request
Jun 03 18:07:17 localhost.localdomain kernel: psmouse serio1: synaptics: queried max coordinates: x [..5712], y [..4780]
Jun 03 18:07:17 localhost.localdomain kernel: psmouse serio1: synaptics: queried min coordinates: x [1232..], y [1074..]
Jun 03 18:08:17 localhost.localdomain kernel: psmouse serio1: TouchPad at isa0060/serio1/input0 lost sync at byte 1

So while I don't have to remove and re-insert rmi_smbus anymore, the touchpad is still not working properly.

Having to resort to a proper USB mouse all the time is somewhat less than ideal.

Anything I can do to try and help to solve this issue?

Comment 3 Steve 2018-06-16 13:41:11 UTC
About a week or so ago, there was a libinput update (1.11) and I haven't had the above issues any more. However, I haven't removed the kernel parameter

psmouse.synaptics_intertouch=0

yet, either.

Comment 4 Justin M. Forbes 2018-07-23 14:57:39 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 28 kernel bugs.

Fedora 28 has now been rebased to 4.17.7-200.fc28.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 5 Steve 2018-08-04 07:07:52 UTC
The issue still occurs but much less frequently now. 
Moreover, I believe it might be potentially related to overheating.

Most of the time when this happens, I have been editing raw photos in darktable and the trackpad tends to stop working after I have been working on a number of photos involving CPU intensive operations which result in the whole laptop getting fairly hot.

This bug can probably be closed for now as the issue happens much less frequently now and might also be more hardware design rather than software related.

I will re-open/open a new bug report should the problem reoccur in a more reproducible manner.

Comment 6 Laura Abbott 2018-10-01 21:15:23 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 28 kernel bugs.
 
Fedora 28 has now been rebased to 4.18.10-300.fc28.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 29, and are still experiencing this issue, please change the version to Fedora 29.
 
If you experience different issues, please open a new bug report for those.

Comment 7 Steve 2018-10-29 17:41:10 UTC
Commnent 5 still holds. It still occurs but much less frequently.
Moreover, the workaround of "rmmod rmi_smbus & insmod rmi_smbus" does not work, either. So something got fixed but some residual issue remains.
However, as I said, it's nowhere near as frequent any more and as such I'll close this as "NotABug"


Note You need to log in before you can comment on or make changes to this bug.