Bug 1567579 - upgrade failed with error "The requested handler 'restart master controllers' was not found"
Summary: upgrade failed with error "The requested handler 'restart master controllers'...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Michael Gugino
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-15 03:11 UTC by Weihua Meng
Modified: 2018-07-30 19:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:12:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:13:33 UTC

Description Weihua Meng 2018-04-15 03:11:02 UTC
Description of problem:
upgrade failed with error "The requested handler 'restart master controllers' was not found" in either the main handlers list nor in the listening handlers list

---
- name: modify controller args
  yedit:
    src: /etc/origin/master/master-config.yaml
    edits:
    - key: kubernetesMasterConfig.controllerArguments.cluster-signing-cert-file
      value:
      - /etc/origin/master/ca.crt
    - key: kubernetesMasterConfig.controllerArguments.cluster-signing-key-file
      value:
      - /etc/origin/master/ca.key
  notify:
  - restart master controllers
  - restart master api

Version-Release number of the following components:
openshift-ansible-3.10.0-0.21.0.git.0.0b1d180.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. upgrade OCP 3.9 to 3.10

Actual results:
TASK [openshift_control_plane : modify controller args] ******************************************************************************
task path: /usr/share/ansible/openshift-ansible/roles/openshift_control_plane/tasks/bootstrap_settings.yml:2
Using module file /usr/share/ansible/openshift-ansible/roles/lib_utils/library/yedit.py
<qe-wmengah39-master-etcd-1.0414-7vl.qe.rhcloud.com> ESTABLISH SSH CONNECTION FOR USER: root
.....

ERROR! The requested handler 'restart master controllers' was not found in either the main handlers list nor in the listening handlers list

Expected results:
Upgrade succeeds without error

Comment 2 Michael Gugino 2018-04-16 19:31:27 UTC
PR Created in master: https://github.com/openshift/openshift-ansible/pull/7982

Comment 3 Weihua Meng 2018-04-21 07:07:35 UTC
Fixed.
openshift-ansible-3.10.0-0.26.0.git.0.dbc127c.el7.noarch

  Operating System: Red Hat Enterprise Linux Server 7.5 (Maipo)
       CPE OS Name: cpe:/o:redhat:enterprise_linux:7.5:GA:server
            Kernel: Linux 3.10.0-862.el7.x86_64

Comment 5 errata-xmlrpc 2018-07-30 19:12:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.