Bug 1567580 - old openshift binary copy to host due to wrong CLI image used
Summary: old openshift binary copy to host due to wrong CLI image used
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Scott Dodson
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-15 04:20 UTC by Weihua Meng
Modified: 2018-07-30 19:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:13:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:13:21 UTC

Description Weihua Meng 2018-04-15 04:20:32 UTC
Description of problem:
For non-RPM install
old openshift binary copy to host due to wrong CLI image used

Version-Release number of the following components:
openshift-ansible-3.10.0-0.21.0.git.0.0b1d180.el7.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. non-RPM install OCP 3.10 

Actual results:
TASK [openshift_cli : Pull CLI Image] ******************************************
Saturday 14 April 2018  22:14:15 -0400 (0:00:00.041)       0:04:57.003 ******** 

ok: [qe-wmengah310nwc-master-etcd-1.0414-iuq.qe.rhcloud.com] => {"changed": false, "cmd": ["atomic", "pull", "--storage", "ostree", "registry.reg-aws.openshift.com:443/openshift3/node:v3.10"], "delta": "0:00:02.208618", "end": "2018-04-15 02:15:16.728095", "failed": false, "rc": 0, "start": "2018-04-15 02:15:14.519477", "stderr": "", "stderr_lines": [], "stdout": "Getting image source signatures\nSkipping fetch of repeat blob sha256:9a32f102e6778e4b3c677f1f93fa121808006d3c9e002237677248de9acb9589\nSkipping fetch of repeat blob sha256:b8aa42cec17a56aea47fa45bd8029d1e877b21213017e849a839aadba9e1486c\nSkipping fetch of repeat blob sha256:5f266895e10e0e1a759b1262e4896db1bdc13f950b2f8963f7ac7cf5096ce1cb\nSkipping fetch of repeat blob sha256:cbc79d274ee1d4a031a0694aa81457f7fc3e4b21a2c725f7cbe829270ddfc3f0\nSkipping fetch of repeat blob sha256:c44cee549c97ac26a72557cd682ecfc39cf174131ecf21de3f93ee83a6204d3d\nCopying config sha256:4635523a519593d60f57fc7078b3421a4dbc49732d9f2997517df3e93f7b1fe5\n\r 0 B / 4.43 KB \r 4.43 KB / 4.43 KB  0s\nWriting manifest to image destination\nStoring signatures", "stdout_lines": ["Getting image source signatures", "Skipping fetch of repeat blob sha256:9a32f102e6778e4b3c677f1f93fa121808006d3c9e002237677248de9acb9589", "Skipping fetch of repeat blob sha256:b8aa42cec17a56aea47fa45bd8029d1e877b21213017e849a839aadba9e1486c", "Skipping fetch of repeat blob sha256:5f266895e10e0e1a759b1262e4896db1bdc13f950b2f8963f7ac7cf5096ce1cb", "Skipping fetch of repeat blob sha256:cbc79d274ee1d4a031a0694aa81457f7fc3e4b21a2c725f7cbe829270ddfc3f0", "Skipping fetch of repeat blob sha256:c44cee549c97ac26a72557cd682ecfc39cf174131ecf21de3f93ee83a6204d3d", "Copying config sha256:4635523a519593d60f57fc7078b3421a4dbc49732d9f2997517df3e93f7b1fe5", "", " 0 B / 4.43 KB ", " 4.43 KB / 4.43 KB  0s", "Writing manifest to image destination", "Storing signatures"]}

TASK [openshift_cli : Copy client binaries/symlinks out of CLI image for use on the host] ***
Saturday 14 April 2018  22:14:18 -0400 (0:00:02.695)       0:04:59.698 ******** 

changed: [qe-wmengah310nwc-master-etcd-1.0414-iuq.qe.rhcloud.com] => {"changed": true, "failed": false, "output": ["Moved /tmp/tmp8rgWpl/openshift to /usr/local/bin/openshift.", "Moved /tmp/tmp8rgWpl/oc to /usr/local/bin/oc.", "Symlinked /usr/local/bin/kubectl to /usr/local/bin/oc."]}

# openshift version
openshift v3.10.0-0.14.0

Expected results:
latest openshift binary copied to host.
got latest openshift version v3.10.0-0.21.0

image openshift3/ose-node:v3.10 should replace openshift3/node:v3.10

Comment 2 Weihua Meng 2018-04-25 06:28:14 UTC
Fixed.
openshift-ansible-3.10.0-0.28.0


# oc version
oc v3.10.0-0.28.0
kubernetes v1.10.0+b81c8f8
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://qe-wmengah310-master-etcd-1:8443
openshift v3.10.0-0.28.0
kubernetes v1.10.0+b81c8f8

TASK [openshift_cli : Pull CLI Image] ******************************************
Tuesday 24 April 2018  23:12:08 -0400 (0:00:00.033)       0:05:45.896 ********* 
ok: [qe-wmengah310-master-etcd-1.0424-zfa.qe.rhcloud.com] => {"changed": false, "cmd": ["atomic", "pull", "--storage", "ostree", "registry.reg-aws.openshift.com:443/openshift3/ose-node:v3.10"], 

Kernel Version: 3.10.0-862.el7.x86_64
Operating System: Red Hat Enterprise Linux Atomic Host 7.5.0
&
Kernel Version: 3.10.0-862.el7.x86_64
Operating System: Red Hat Enterprise Linux Server 7.5 (Maipo)

Comment 4 errata-xmlrpc 2018-07-30 19:13:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.