Bug 1567582 - Not compatible with libva 2.x
Summary: Not compatible with libva 2.x
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libva-intel-hybrid-driver
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Robert-André Mauchin 🐧
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1595954 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-15 05:18 UTC by Michael Cronenworth
Modified: 2018-08-18 11:40 UTC (History)
5 users (show)

Fixed In Version: libva-intel-hybrid-driver-1.0.2-13.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-03 16:53:33 UTC
Type: Bug


Attachments (Terms of Use)

Description Michael Cronenworth 2018-04-15 05:18:22 UTC
Description of problem:
The hybrid driver works for Fedora <28 but not with Fedora >=28.


Version-Release number of selected component (if applicable):
libva-2.1.0-1.fc28.x86_64
libva-intel-driver-2.1.0-2.fc28.x86_64
libva-intel-hybrid-driver-1.0.2-10.fc28.x86_64

Actual results:
$ vainfo 
libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_1
/usr/lib64/dri/hybrid_drv_video.so init failed
Failed to wrapper hybrid_drv_video.so


Expected results:
Successful open. VP9 decoder listed.

Additional info:
Upstream has a couple of commits to support libva 2.x but has not released a formal update.

Comment 1 Robert-André Mauchin 🐧 2018-04-15 10:44:18 UTC
> Upstream has a couple of commits to support libva 2.x but has not released a formal update.

These commits are already included as a patch in libva-intel-hybrid-driver-1.0.2. I guess they do not make it compatible. I'll report upstream and see what they have to say.

Comment 2 Robert-André Mauchin 🐧 2018-06-27 22:05:18 UTC
*** Bug 1595954 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2018-06-27 22:25:16 UTC
libva-intel-hybrid-driver-1.0.2-12.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7ff3135342

Comment 4 Robert-André Mauchin 🐧 2018-06-27 22:31:53 UTC
Thanks to a user-contributed pull request on Intel's Github, the issue is solved. I have pushed a new update and it will be available in updates-testing within two days.

Comment 5 louisgtwo 2018-06-28 00:37:50 UTC
I am still having problems.

libva-intel-driver-2.1.0-2.fc28.x86_64
libva-intel-hybrid-driver-1.0.2-12.fc28.x86_64
libva-2.1.0-1.fc28.x86_64

$ vainfo
libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_1
/usr/lib64/dri/hybrid_drv_video.so init failed
Failed to wrapper hybrid_drv_video.so
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.1 (libva 2.1.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Broadwell - 2.1.0
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Simple            :	VAEntrypointEncSlice
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSlice
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointEncSlice
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointEncSlice
      VAProfileH264MultiviewHigh      :	VAEntrypointVLD
      VAProfileH264MultiviewHigh      :	VAEntrypointEncSlice
      VAProfileH264StereoHigh         :	VAEntrypointVLD
      VAProfileH264StereoHigh         :	VAEntrypointEncSlice
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD
      VAProfileNone                   :	VAEntrypointVideoProc
      VAProfileJPEGBaseline           :	VAEntrypointVLD
      VAProfileVP8Version0_3          :	VAEntrypointVLD

Comment 6 Robert-André Mauchin 🐧 2018-06-28 09:23:24 UTC
The hybrid driver should work on Haswell and Skylake, not Broadwell.

Comment 7 Robert-André Mauchin 🐧 2018-06-28 09:32:53 UTC
Actually VP9 decodeng is not supported on Haswell either, only Skylake.

Comment 8 Fedora Update System 2018-06-28 15:05:12 UTC
libva-intel-hybrid-driver-1.0.2-12.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7ff3135342

Comment 9 louisgtwo 2018-06-28 16:05:37 UTC
Should there be a better error? Failed to wapper hybrid_drv_video.so seems like something broke. How about not supported on this platform?

Comment 10 lejeczek 2018-06-28 20:11:32 UTC
I'm on a skylake i5-6300U, and I still get that error:

$ vainfo 
libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_1
/usr/lib64/dri/hybrid_drv_video.so init failed
Failed to wrapper hybrid_drv_video.so
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.1 (libva 2.1.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Skylake - 2.1.0
vainfo: Supported profile and entrypoints

and no vp9.

hybrid: 1.0.2-12.fc28
@ 4.17.3-200.fc28.x86_64

@ #7 thus the hybrid driver, from what I understand it does some magic so there vp9 on skylake.

Comment 11 Fedora Update System 2018-06-28 20:48:08 UTC
libva-intel-hybrid-driver-1.0.2-13.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-bdc3240f72

Comment 12 Robert-André Mauchin 🐧 2018-06-28 20:51:33 UTC
I get this on Skylake:

$ vainfo
libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_1
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.1 (libva 2.1.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Skylake - 2.1.0
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Simple            : VAEntrypointEncSlice
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSliceLP
      VAProfileH264ConstrainedBaseline: VAEntrypointFEI
      VAProfileH264ConstrainedBaseline: VAEntrypointStats
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointEncSliceLP
      VAProfileH264Main               : VAEntrypointFEI
      VAProfileH264Main               : VAEntrypointStats
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointEncSliceLP
      VAProfileH264High               : VAEntrypointFEI
      VAProfileH264High               : VAEntrypointStats
      VAProfileH264MultiviewHigh      : VAEntrypointVLD
      VAProfileH264MultiviewHigh      : VAEntrypointEncSlice
      VAProfileH264StereoHigh         : VAEntrypointVLD
      VAProfileH264StereoHigh         : VAEntrypointEncSlice
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileJPEGBaseline           : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointEncPicture
      VAProfileVP8Version0_3          : VAEntrypointVLD
      VAProfileVP8Version0_3          : VAEntrypointEncSlice
      VAProfileHEVCMain               : VAEntrypointVLD
      VAProfileHEVCMain               : VAEntrypointEncSlice
      VAProfileVP9Profile0            : VAEntrypointVLD


Wait I might have found an issue with the patch which explains why it works for me and not for you(s).

I've pushed another update, it will be available in updates-testing soon.

Comment 13 louisgtwo 2018-06-28 21:30:08 UTC
Ok latest version -13 fix it for me

Comment 14 Fedora Update System 2018-06-29 09:46:59 UTC
libva-intel-hybrid-driver-1.0.2-13.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-bdc3240f72

Comment 15 Fedora Update System 2018-07-03 16:53:33 UTC
libva-intel-hybrid-driver-1.0.2-13.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 lejeczek 2018-07-11 22:36:12 UTC
do we have a way of testing it. I mean, other than for the vainfo?
I'm trying vlc, kodi, and trying VP9 4K video is futile, so slow that I can say: no playback.

Comment 17 Robert-André Mauchin 🐧 2018-07-12 05:18:53 UTC
You can test it with mpv with option hwdec=vaapi


Note You need to log in before you can comment on or make changes to this bug.