Bug 1567587 - [abrt] recoll: std::__replacement_assert(): recollindex killed by SIGABRT
Summary: [abrt] recoll: std::__replacement_assert(): recollindex killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1577613
Alias: None
Product: Fedora
Classification: Fedora
Component: recoll
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Terje Røsten
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:9a19cfa909ff44cf2397ac771cd...
: 1575158 1579143 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-15 06:28 UTC by cornosier
Modified: 2018-05-17 05:14 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-16 05:31:10 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (17.14 KB, text/plain)
2018-04-15 06:28 UTC, cornosier
no flags Details
File: cgroup (331 bytes, text/plain)
2018-04-15 06:28 UTC, cornosier
no flags Details
File: core_backtrace (3.99 KB, text/plain)
2018-04-15 06:28 UTC, cornosier
no flags Details
File: cpuinfo (1.75 KB, text/plain)
2018-04-15 06:28 UTC, cornosier
no flags Details
File: dso_list (1.38 KB, text/plain)
2018-04-15 06:28 UTC, cornosier
no flags Details
File: environ (295 bytes, text/plain)
2018-04-15 06:28 UTC, cornosier
no flags Details
File: limits (1.29 KB, text/plain)
2018-04-15 06:28 UTC, cornosier
no flags Details
File: maps (7.25 KB, text/plain)
2018-04-15 06:28 UTC, cornosier
no flags Details
File: mountinfo (3.30 KB, text/plain)
2018-04-15 06:28 UTC, cornosier
no flags Details
File: open_fds (255 bytes, text/plain)
2018-04-15 06:28 UTC, cornosier
no flags Details
File: proc_pid_status (1.26 KB, text/plain)
2018-04-15 06:28 UTC, cornosier
no flags Details

Description cornosier 2018-04-15 06:28:20 UTC
Description of problem:
à la sortie de veille

Version-Release number of selected component:
recoll-1.23.7-2.fc28

Additional info:
reporter:       libreport-2.9.4
backtrace_rating: 4
cmdline:        recollindex
crash_function: std::__replacement_assert
executable:     /usr/bin/recollindex
journald_cursor: s=6d95899fc2eb4bb1ba9414bd8673d010;i=c9a3;b=261d3229da95445a87d8bd8b1dc77c3d;m=2f0d8dc1a;t=569dd27fbbe33;x=9108a8b30da7bee2
kernel:         4.16.1-300.fc28.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 std::__replacement_assert at /usr/include/c++/8/x86_64-redhat-linux/bits/c++config.h:2389
 #3 std::vector<regmatch_t, std::allocator<regmatch_t> >::operator[] at utils/smallut.cpp:1299
 #4 SimpleRegexp::simpleMatch at utils/smallut.cpp:1299
 #5 ConfSimple::parseinput(std::istream&) at utils/conftree.cpp:110
 #6 ConfSimple::ConfSimple(char const*, int, bool, bool) at utils/conftree.cpp:222
 #7 ConfTree::ConfTree at ./utils/conftree.h:396
 #8 ConfStack<ConfTree>::construct at ./utils/conftree.h:586
 #9 ConfStack<ConfTree>::ConfStack at ./utils/conftree.h:402
 #10 RclConfig::updateMainConfig() at common/rclconfig.cpp:344
 #11 RclConfig::RclConfig(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const*) at common/rclconfig.cpp:306

Comment 1 cornosier 2018-04-15 06:28:26 UTC
Created attachment 1422074 [details]
File: backtrace

Comment 2 cornosier 2018-04-15 06:28:27 UTC
Created attachment 1422075 [details]
File: cgroup

Comment 3 cornosier 2018-04-15 06:28:29 UTC
Created attachment 1422076 [details]
File: core_backtrace

Comment 4 cornosier 2018-04-15 06:28:31 UTC
Created attachment 1422077 [details]
File: cpuinfo

Comment 5 cornosier 2018-04-15 06:28:33 UTC
Created attachment 1422078 [details]
File: dso_list

Comment 6 cornosier 2018-04-15 06:28:34 UTC
Created attachment 1422079 [details]
File: environ

Comment 7 cornosier 2018-04-15 06:28:36 UTC
Created attachment 1422080 [details]
File: limits

Comment 8 cornosier 2018-04-15 06:28:37 UTC
Created attachment 1422081 [details]
File: maps

Comment 9 cornosier 2018-04-15 06:28:39 UTC
Created attachment 1422082 [details]
File: mountinfo

Comment 10 cornosier 2018-04-15 06:28:41 UTC
Created attachment 1422083 [details]
File: open_fds

Comment 11 cornosier 2018-04-15 06:28:42 UTC
Created attachment 1422084 [details]
File: proc_pid_status

Comment 12 cornosier 2018-04-15 15:35:59 UTC
Similar problem has been detected:

when launching the application

reporter:       libreport-2.9.4
backtrace_rating: 4
cmdline:        /usr/bin/recoll
crash_function: std::__replacement_assert
executable:     /usr/bin/recoll
journald_cursor: s=6d95899fc2eb4bb1ba9414bd8673d010;i=d2be;b=261d3229da95445a87d8bd8b1dc77c3d;m=73b5dd470;t=569e4c219db1f;x=f15016dc50d8f190
kernel:         4.16.1-300.fc28.x86_64
package:        recoll-1.23.7-2.fc28
reason:         recoll killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 13 hannes 2018-05-04 08:11:56 UTC
Similar problem has been detected:

Just tried to start the program. 

reporter:       libreport-2.9.5
backtrace_rating: 4
cmdline:        recoll
crash_function: std::__replacement_assert
executable:     /usr/bin/recoll
journald_cursor: s=922b2b018c3c4305ba96f47499ca69bc;i=121854;b=de51a87c53ee4a679021a6f67bb12f1a;m=1122c9f4d;t=56b5ccbbc1a4f;x=d59d0982e512194f
kernel:         4.16.6-300.fc28.x86_64
package:        recoll-1.23.7-2.fc28
reason:         recoll killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1001

Comment 14 Garry 2018-05-04 23:07:42 UTC
*** Bug 1575158 has been marked as a duplicate of this bug. ***

Comment 15 Boricua 2018-05-10 16:17:26 UTC
Similar problem has been detected:

Recoll crashes at launch. It happens on both fresh installed and upgraded Fedora 28 systems.

reporter:       libreport-2.9.5
backtrace_rating: 3
cmdline:        recoll
crash_function: std::__replacement_assert
executable:     /usr/bin/recoll
journald_cursor: s=8eda667a3ee64a5788b92a276fa47060;i=35289;b=4297a56c45fe4b54802b171c44b2eb37;m=160d58dc4;t=56bdc444bd7e9;x=16ef9844a71a2b7a
kernel:         4.16.7-300.fc28.x86_64
package:        recoll-1.23.7-2.fc28
reason:         recoll killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 16 hannes 2018-05-16 05:31:10 UTC

*** This bug has been marked as a duplicate of bug 1577613 ***

Comment 17 Andrew Lucas 2018-05-17 05:14:56 UTC
*** Bug 1579143 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.