Bug 1567599 - Please update this package on Fedora 27 and 28
Summary: Please update this package on Fedora 27 and 28
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qalculate-gtk
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-15 09:33 UTC by Christian Stadelmann
Modified: 2018-05-22 15:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-22 15:07:29 UTC
Type: Bug


Attachments (Terms of Use)

Description Christian Stadelmann 2018-04-15 09:33:22 UTC
Can we please have more recent versions of Qalculate on Fedora 27 and 28?

Comment 1 Mukundan Ragavan 2018-04-15 13:10:36 UTC
I am hoping to update F28. But, F27 is unlikely since it has a soname change.

Comment 2 Dragan 2018-05-10 19:21:40 UTC
Second that, the current version is useless, it crashes with all but the simplest expressions:



[galileo@sol ~]$ qalc 5 + 2 
5 + 2 = 7

[galileo@sol ~]$ qalc x + 2 = 7
/usr/include/c++/8/bits/basic_string.h:1048: std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::operator[](std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type) [with _CharT = char; _Traits = std::char_traits<char>; _Alloc = std::allocator<char>; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference = char&; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type = long unsigned int]: Assertion '__pos <= size()' failed.
Aborted (core dumped)

Comment 3 Mukundan Ragavan 2018-05-10 22:24:16 UTC
Sadly, this is not an issue with just the old versions. Here it is in action in qalculate-2.4.0 on my system for the exact same equation.

$ qalculate-gtk 
/usr/include/c++/8/bits/basic_string.h:1048: std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::operator[](std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type) [with _CharT = char; _Traits = std::char_traits<char>; _Alloc = std::allocator<char>; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference = char&; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type = long unsigned int]: Assertion '__pos <= size()' failed.
Aborted (core dumped)


I will file a bug report upstream. But, regarding the update, can you try this COPR?

https://copr.fedorainfracloud.org/coprs/nonamedotc/libqalculate/

Comment 4 schlaffi 2018-05-11 13:43:19 UTC
qakculate-gtk is also unusable here, crashes with a lot of simple calculations, e.g. binomial(3,1). Compiling 2.4.0 seems to work.

Comment 5 Christian Stadelmann 2018-05-11 18:17:55 UTC
(In reply to Mukundan Ragavan from comment #3)
> Sadly, this is not an issue with just the old versions. Here it is in action
> in qalculate-2.4.0 on my system for the exact same equation.

Yes, it is. Qalculate 2.4.0 is stable for me on Windows at least. Are you sure you are using 2.4.0 and not the old one?

(In reply to Mukundan Ragavan from comment #3)
> I will file a bug report upstream. But, regarding the update, can you try
> this COPR?
> 
> https://copr.fedorainfracloud.org/coprs/nonamedotc/libqalculate/

The copr packages have broken dependencies. I cannot update to these versions because they will uninstall plasma-workspace and plasma-desktop. This is probably caused by the fact that there are two identical versions of plasma-workspace{-common,-libs}, one from your copr and one in Fedora's "updates" repository.

Comment 6 Mukundan Ragavan 2018-05-11 22:29:50 UTC
(In reply to Christian Stadelmann from comment #5)
> (In reply to Mukundan Ragavan from comment #3)
> > Sadly, this is not an issue with just the old versions. Here it is in action
> > in qalculate-2.4.0 on my system for the exact same equation.
> 
> Yes, it is. Qalculate 2.4.0 is stable for me on Windows at least. Are you
> sure you are using 2.4.0 and not the old one?
> 

Yes. I know I am using the right version.

$ qalculate-gtk -v
2.4.0


> (In reply to Mukundan Ragavan from comment #3)
> > I will file a bug report upstream. But, regarding the update, can you try
> > this COPR?
> > 
> > https://copr.fedorainfracloud.org/coprs/nonamedotc/libqalculate/
> 
> The copr packages have broken dependencies. I cannot update to these
> versions because they will uninstall plasma-workspace and plasma-desktop.
> This is probably caused by the fact that there are two identical versions of
> plasma-workspace{-common,-libs}, one from your copr and one in Fedora's
> "updates" repository.

That is expected. That COPR is my test repo. I use packages from that.

There is soname bump with each version of qalculate. This is the reason why I cannot push new versions of qalculate to stable releases. We generally do not push updates with soname bumps to stable releases.

I wanted to get this done for F28 but fell through.

Can you file a bug upstream?

Comment 7 Fedora Update System 2018-05-19 11:16:20 UTC
libqalculate-2.0.0-6.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-4167f9ffee

Comment 8 Mukundan Ragavan 2018-05-19 11:17:34 UTC
This is not really an update to 2.4 or 2.5 versions. But, I have added a patch to ensure qalculate does not crash on regular usage.

Please test and add karma on bodhi (link in comment #7)

Comment 9 Fedora Update System 2018-05-19 23:27:48 UTC
libqalculate-2.0.0-6.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-4167f9ffee

Comment 10 Christian Stadelmann 2018-05-20 09:33:56 UTC
How about having a "compat" libqalculate 2.0.0 without the API bump plus a "regular" stable libqalculate with qalculate-gtk? The latter one could be updated regularly because it has no dependencies, the former will be stable to meet the API/ABI stability guarantee needed for KDE's plasma and possibly other stuff.

Comment 11 Mukundan Ragavan 2018-05-20 13:54:43 UTC
Is there any advantage in updating just qalculate-gtk without the backend? 

I can certainly update qalculate-gtk if there are advantages.

Comment 12 Mukundan Ragavan 2018-05-20 13:57:48 UTC
Oh wait! I forgot. qalculate-gtk requires matching version of libqalculate. :(

I cannot updates these independently.

Comment 13 Fedora Update System 2018-05-22 15:07:29 UTC
libqalculate-2.0.0-6.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.