Bug 1567603 - [CodeChange] Cleanup create snapshot code after requiring qemu > 2.10
Summary: [CodeChange] Cleanup create snapshot code after requiring qemu > 2.10
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: vdsm
Classification: oVirt
Component: Core
Version: 4.20.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.4
: ---
Assignee: Ala Hino
QA Contact: Avihai
URL:
Whiteboard:
Depends On: 1567806
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-15 11:16 UTC by Ala Hino
Modified: 2018-06-26 08:45 UTC (History)
4 users (show)

Fixed In Version: vdsm v4.20.29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:45:14 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+
ylavi: exception+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 86599 0 master MERGED qemuimg: Remove _supports_option 2018-05-27 07:44:11 UTC
oVirt gerrit 86600 0 master MERGED volume: Cleanup prepare/teardown logic 2018-05-27 07:43:05 UTC
oVirt gerrit 91649 0 ovirt-4.2 MERGED volume: Cleanup prepare/teardown logic 2018-05-28 10:43:02 UTC
oVirt gerrit 91650 0 ovirt-4.2 MERGED qemuimg: Remove _supports_option 2018-05-28 10:43:06 UTC

Description Ala Hino 2018-04-15 11:16:44 UTC
Description of problem:
After requiring qemu-img 2.10, we don't have to check if
prepare/teardown volumes is required. The logic of checking whether
prepare/teardown is required added in commit 7222af88 (create-snapshot:
Use unsafe option when creating snapshots), when at that time we still
used qemu-img<2.10 that didn't support unsafe operations

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Avihai 2018-06-10 11:18:56 UTC
Verified, ran sanity(Tier1) tests on fixed build 4.2.4 and tests passed.

Comment 4 Sandro Bonazzola 2018-06-26 08:45:14 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.