Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1567621 - The "Save" button doesn't appear after changing the deployment counters for the 1st time
Summary: The "Save" button doesn't appear after changing the deployment counters for t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: Upstream M3
: 14.0 (Rocky)
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks: 1620160
TreeView+ depends on / blocked
 
Reported: 2018-04-15 14:49 UTC by Udi
Modified: 2019-01-11 11:49 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-ui-9.1.1-0.20180710115855.7dd171e.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1620160 (view as bug list)
Environment:
Last Closed: 2019-01-11 11:49:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
Proposed error message to clarify the situation (192.96 KB, image/png)
2018-05-09 12:47 UTC, Jiri Tomasek
no flags Details


Links
System ID Private Priority Status Summary Last Updated
OpenStack Storyboard 2001990 0 None None None 2018-05-09 13:31:08 UTC
OpenStack gerrit 558927 0 None master: MERGED tripleo-heat-templates: Switch to config-download by default (I8389a0c48e1aa610fdc6a8580516889340883034) 2018-07-05 18:32:27 UTC
OpenStack gerrit 567221 0 None master: MERGED tripleo-ui: Add general error message to NodesAssignmentForm (I5c6de6726c202c2a631d78a2c7890db5fd2d5b7b) 2018-07-05 18:32:22 UTC
Red Hat Product Errata RHEA-2019:0045 0 None None None 2019-01-11 11:49:53 UTC

Description Udi 2018-04-15 14:49:15 UTC
Description of problem:
After uploading a new plan and increasing the controllers count to 3, you can't save the changes. The "Manage Roles" button is still displayed. Only after updating more counters do you get the "Save" and "Cancel" buttons.


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-8.3.1-2.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Upload a new plan and browse to its deployment page
2. Edit the "Controller" role and set its flavor to "control"
3. Save and close the role editing dialog
4. Update the controller count to 3
5. See if you can save the changes...


Actual results:
No "Save" button


Expected results:
The "Save" and "Cancel" buttons should appear, and the "Manage Roles" button should disappear.


Additional info:
After updating the compute role and counters the problem is resolved.

Comment 1 Jason E. Rist 2018-04-25 14:57:24 UTC
Please attach the plan you used.

Comment 2 Jiri Tomasek 2018-04-25 15:09:01 UTC
I am going to investigate further, but the button should appear in case when the nodes assignment form (the counters) is valid && dirty && !submitting. Was one of the counters red? I assume that when you create plan initially, the controller and compute counts are set to 1. In case when there are no nodes ready yet, both are red so until one of the counts are red the save button will not appear.

Comment 3 Udi 2018-05-08 14:22:15 UTC
The plan is just the default plan which you can create with:
tar -czf plan.tgz -C /usr/share/openstack-tripleo-heat-templates/ .

Jiri, you are also right. When the plan is new you have to configure the flavors for both the controller role and the compute role, and until then the counters are red. After configuring the 2nd role you get the save button. Is there a way to make it more clear to the user?

Comment 4 Jiri Tomasek 2018-05-09 12:47:37 UTC
Created attachment 1433806 [details]
Proposed error message to clarify the situation

Comment 5 Jiri Tomasek 2018-05-09 12:47:57 UTC
@Udi: We can provide an error message describing the situation. Would that be sufficient/helpful? (See attachment)

Comment 6 Udi 2018-05-09 13:57:18 UTC
A message describing the problem can help a lot. For example, if the user changes a counter - check if other counters are red and display something telling the user that the changes will only be savable when all counters are valid.

Comment 7 Jason E. Rist 2018-05-09 14:37:37 UTC
Liz can you help with the proposed error message linked here
https://bugzilla.redhat.com/attachment.cgi?id=1433806

Comment 9 Liz 2018-05-21 14:52:44 UTC
Commented on the patch upstream with suggestion...
https://review.openstack.org/#/c/567221/

Comment 16 Udi 2018-10-18 12:07:00 UTC
Verified in openstack-tripleo-ui-9.3.1-0.20180921180341.df30b55.el7ost.noarch

Comment 20 errata-xmlrpc 2019-01-11 11:49:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.