Bug 1567622 - bluetoothd (bluez 5.49) crashes on start: core-dump
Summary: bluetoothd (bluez 5.49) crashes on start: core-dump
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bluez
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Don Zickus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1568225 1569813 1570221 (view as bug list)
Depends On:
Blocks: F28FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-04-15 14:58 UTC by Viliam Križan
Modified: 2018-06-20 04:30 UTC (History)
17 users (show)

Fixed In Version: bluez-5.49-3.fc27 bluez-5.49-3.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-24 11:24:54 UTC
Type: Bug


Attachments (Terms of Use)
File: backtrace (5.52 KB, text/plain)
2018-04-20 13:37 UTC, Damian Wrobel
no flags Details

Description Viliam Križan 2018-04-15 14:58:23 UTC
Description of problem:

After upgrading bluez to 5.49 (F27), the bluetoothd crashes right on start with core-dump.  Interestingly it crashes gnome-control-center.  Note, that version bluez-5.48-3 worked without any problems.

Thank you for fixing the issue.  I've downgraded for now.


Version-Release number of selected component (if applicable):

bluez-5.49-1.fc27


How reproducible:


Steps to Reproduce:
1. $ sudo systemctl restart bluetooth

Actual results:

apr 15 15:13:39 viliam-t500 systemd[1]: bluetooth.service: Main process exited, code=dumped, status=11/SEGV
apr 15 15:13:39 viliam-t500 systemd[1]: bluetooth.service: Unit entered failed state.
apr 15 15:13:39 viliam-t500 systemd[1]: bluetooth.service: Failed with result 'core-dump'.
apr 15 15:13:39 viliam-t500 systemd-coredump[1233]: Process 1192 (bluetoothd) of user 0 dumped core.
 
 Stack trace of thread 1192:
 #0  0x00005617132e92d0 btd_adv_manager_refresh (bluetoothd)
 #1  0x00005617132f54e2 new_settings_callback (bluetoothd)
 #2  0x0000561713324da8 request_complete (bluetoothd)
 #3  0x00005617133258cd can_read_data (bluetoothd)
 #4  0x0000561713331fe3 watch_callback (bluetoothd)
 #5  0x00007ff1bf444b77 g_main_context_dispatch (libglib-2.0.so.0)
 #6  0x00007ff1bf444f20 g_main_context_iterate.isra.23 (libglib-2.0.so.0)
 #7  0x00007ff1bf445232 g_main_loop_run (libglib-2.0.so.0)
 #8  0x00005617132a43fb main (bluetoothd)
 #9  0x00007ff1bea07f2a __libc_start_main (libc.so.6)
 #10 0x00005617132a4cea _start (bluetoothd)


Expected results:

Start normally.

Additional info:

Kernel: 4.15.15-300.fc27.x86_64
Bluetooth chip: 0a5c:2145 Broadcom Corp. BCM2045B (BDC-2.1)
Laptop: Lenovo ThinkPad T500

https://bodhi.fedoraproject.org/updates/FEDORA-2018-5d0bdfb533

Comment 1 Bastien Nocera 2018-04-20 10:05:42 UTC
*** Bug 1568225 has been marked as a duplicate of this bug. ***

Comment 2 Bastien Nocera 2018-04-20 10:05:52 UTC
*** Bug 1569813 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2018-04-20 13:32:18 UTC
bluez-5.49-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-63edc9b104

Comment 4 Damian Wrobel 2018-04-20 13:37:54 UTC
Similar problem has been detected:

I've tried to pair bluetooth mouse.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/libexec/bluetooth/bluetoothd
crash_function: btd_adv_manager_refresh
executable:     /usr/libexec/bluetooth/bluetoothd
journald_cursor: s=757cfe9932774ec58dfe0c88a1d8da14;i=29ee;b=3e2a77d5e08f4173a87b717eebcefb31;m=4687a367;t=56a452e12826d;x=7e93124a0e18a3d6
kernel:         4.13.9-300.fc27.x86_64
package:        bluez-5.49-1.fc27
reason:         bluetoothd killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 5 Damian Wrobel 2018-04-20 13:37:59 UTC
Created attachment 1424505 [details]
File: backtrace

Comment 6 Fedora Update System 2018-04-20 14:23:03 UTC
bluez-5.49-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-bf02f2b894

Comment 7 Michael Dempsey 2018-04-21 00:22:37 UTC
*** Bug 1570221 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2018-04-21 05:03:06 UTC
bluez-5.49-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-bf02f2b894

Comment 9 Fedora Update System 2018-04-21 18:37:54 UTC
bluez-5.49-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-63edc9b104

Comment 10 Andrew 2018-04-22 14:34:51 UTC
Similar problem has been detected:

Connect to device

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/libexec/bluetooth/bluetoothd
crash_function: btd_adv_manager_refresh
executable:     /usr/libexec/bluetooth/bluetoothd
journald_cursor: s=5ff3465cd41f4b498df06f734045b145;i=bc3f9;b=d216c4964a1f42c7b3598b665eec04b3;m=4b19571ba;t=56a5d0750cbfa;x=46e7a40b1105f547
kernel:         4.15.17-300.fc27.x86_64
package:        bluez-5.49-1.fc27
reason:         bluetoothd killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 11 Fedora Blocker Bugs Application 2018-04-22 14:38:41 UTC
Proposed as a Freeze Exception for 28-final by Fedora user pbrobinson using the blocker tracking app because:

 Regresses bluetooth functionality on Workstation (and others that use bluetooth) for some functionality such as input devices (mice etc) and sound, probably printers and other bluetooth attached devices too.

Comment 12 sergiyvovk69 2018-04-22 17:40:50 UTC
Similar problem has been detected:

The problem happens everytime I run the blackberry graphic bluetooth manager.
The blackberry bluetooth manager does not work properly too.
This problem does not exist in fedora from live CD.

If I use the bluetoothctl application in terminal as bluetooth manager,
all my bluetooth devices works normally and there is no problem.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/libexec/bluetooth/bluetoothd
crash_function: btd_adv_manager_refresh
executable:     /usr/libexec/bluetooth/bluetoothd
journald_cursor: s=297e04cd80e540b58233963ecd466936;i=744;b=100bc0c4a55d46cbbc91b9020f48e7f6;m=545f32a;t=56a729c9d2205;x=e7d74f371b17194e
kernel:         4.15.17-300.fc27.x86_64
package:        bluez-5.49-1.fc27
reason:         bluetoothd killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 13 Jirka Jurek 2018-04-23 14:14:11 UTC
Similar problem has been detected:

bluetoothd segfaults right after displaying gnome dialog for managing bluetooth devices.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/libexec/bluetooth/bluetoothd
crash_function: btd_adv_manager_refresh
executable:     /usr/libexec/bluetooth/bluetoothd
journald_cursor: s=af153b270bf34cf1a144957524a55241;i=29ff;b=b867bf381219451da6613389e4531998;m=77a22e7;t=56a84048ae05c;x=f75d9ba780a81e40
kernel:         4.15.17-300.fc27.x86_64
package:        bluez-5.49-1.fc27
reason:         bluetoothd killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 14 Adam Williamson 2018-04-24 01:07:22 UTC
Discussed at 2018-04-23 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-04-23/f28-blocker-review.2018-04-23-16.00.html . This was promoted to and accepted as a Final blocker, as a violation of criterion "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use", as this is a major function which can be reached (and users with bluetooth devices will commonly interact with) via the panel.

Comment 15 Fedora Update System 2018-04-24 04:02:09 UTC
bluez-5.49-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2018-04-24 11:24:54 UTC
bluez-5.49-3.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Wolf Vollprecht 2018-05-28 11:08:43 UTC
Similar problem has been detected:

Trying to start bluetooth.

I was able to fix the issue by recompiling bluez with adding a line checking  `if(manager != NULL) return;`
as is already done upstream.

reporter:       libreport-2.9.5
backtrace_rating: 3
cmdline:        /usr/libexec/bluetooth/bluetoothd
crash_function: btd_adv_manager_refresh
executable:     /usr/libexec/bluetooth/bluetoothd
journald_cursor: s=7960c8d3d61e4ff79371f1f77084fe81;i=a626;b=dd75a333566c453188b6b925883b14f3;m=54414edd1;t=56d40a1ace351;x=ac47f6aef5807d49
kernel:         4.16.11-300.fc28.x86_64
package:        bluez-5.49-3.fc28
reason:         bluetoothd killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 18 Wolf Vollprecht 2018-05-28 11:16:05 UTC
As far as I can tell this Bug is NOT fixed in 5.49-3.

would be great if it could be reopened and the appropriate patch from https://bugzilla.redhat.com/show_bug.cgi?id=1569813 applied.


Note You need to log in before you can comment on or make changes to this bug.