Bug 1567650 - installing protobuf and go libraries fails transaction check for /usr/bin/protoc
Summary: installing protobuf and go libraries fails transaction check for /usr/bin/protoc
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-googlecode-goprotobuf
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Fridolín Pokorný
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-15 18:51 UTC by Hayden
Modified: 2018-05-19 03:37 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-05-19 02:01:07 UTC


Attachments (Terms of Use)

Description Hayden 2018-04-15 18:51:56 UTC
Description of problem:

sudo dnf install golang-googlecode-goprotobuf protobuf-compiler

Error: Transaction check error:
  file /usr/bin/protoc from install of protobuf-compiler-3.5.0-4.fc28.x86_64 conflicts with file from package golang-googlecode-goprotobuf-0-0.36.20180318git5afd06f.fc28.x86_64


How reproducible: Very


Steps to Reproduce:
1. sudo dnf install golang-googlecode-goprotobuf protobuf-compiler

Actual results:

Cannot install golang-googlecode-goprotobuf and protobuf-compiler packages from repos

Expected results:

Can install protobuf-compiler and goloang libraries packages from repos

Additional info:

Comment 1 Hayden 2018-04-15 18:52:49 UTC
fyi, I am trying to build https://github.com/evilsocket/opensnitch

Comment 2 Jan Pazdziora 2018-04-19 11:15:25 UTC
Hitting the same error when upgrading existing installation of

# rpm -q golang-googlecode-goprotobuf protobuf-compiler
golang-googlecode-goprotobuf-0-0.30.git24f28ae.fc27.x86_64
protobuf-compiler-3.3.1-2.fc27.x86_64

file /usr/bin/protoc from install of golang-googlecode-goprotobuf-0-0.36.20180318git5afd06f.fc27.x86_64 conflicts with file from package protobuf-compiler-3.3.1-2.fc27.x86_64

The original version golang-googlecode-goprotobuf-0-0.30.git24f28ae.fc27.x86_64 ships

# rpm -ql golang-googlecode-goprotobuf-0-0.30.git24f28ae.fc27.x86_64 | grep /usr/bin
/usr/bin/protoc-gen-go

and since it is changing the location of the binary, it should either use Provides or Obsoletes, or use alternatives.

Comment 3 Robert-André Mauchin 2018-05-07 20:45:32 UTC
I made a PR addressing this: https://src.fedoraproject.org/rpms/golang-googlecode-goprotobuf/pull-request/1

Stay tuned.

Comment 4 Fedora Update System 2018-05-09 12:53:11 UTC
golang-googlecode-goprotobuf-0-0.37.20180318git5afd06f.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c7cd00c465

Comment 5 Fedora Update System 2018-05-09 12:53:26 UTC
golang-googlecode-goprotobuf-0-0.37.20180318git5afd06f.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cc209069b2

Comment 6 Fedora Update System 2018-05-09 23:31:43 UTC
golang-googlecode-goprotobuf-0-0.37.20180318git5afd06f.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c7cd00c465

Comment 7 Fedora Update System 2018-05-10 01:31:21 UTC
golang-googlecode-goprotobuf-0-0.37.20180318git5afd06f.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cc209069b2

Comment 8 Fedora Update System 2018-05-19 02:01:07 UTC
golang-googlecode-goprotobuf-0-0.37.20180318git5afd06f.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2018-05-19 03:37:11 UTC
golang-googlecode-goprotobuf-0-0.37.20180318git5afd06f.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.