Bug 1567729 - Request to move udisks2-lvm2 and udisks2-iscsi subpackages from optional to base or extras
Summary: Request to move udisks2-lvm2 and udisks2-iscsi subpackages from optional to b...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Djordje Todorovic
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 06:02 UTC by Martin Pitt
Modified: 2019-03-22 11:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-22 11:54:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Pitt 2018-04-16 06:02:45 UTC
Description of problem: Bug 1503100 recently got closed (and cannot be reopened), but is not actually fixed at all: udisks2-{lvm2,iscsi} are still not in RHEL 7.5 base or even extras, but still in optional:

# yum info udisks2-lvm2
Installed Packages
Name        : udisks2-lvm2
Arch        : x86_64
Version     : 2.7.3
Release     : 6.el7
Size        : 197 k
Repo        : installed
From repo   : rhel-7-server-optional-rpms

This makes cockpit-storaged uninstallable, which was reported in bug 1510667 and on IRC.


Version-Release number of selected component (if applicable):

RHEL 7.5.0

How reproducible: Always


Steps to Reproduce:
1. yum-config-manager --enable rhel-7-server-extras-rpms
2. yum install cockpit-storaged

Actual results: Package fails to install due to missing udisks2-lvm2 and -iscsi dependencies.


Expected results: Package installs.

Comment 2 Lubos Kocman 2018-05-28 14:52:51 UTC
This has already happened. Moving to RTT for re-test.


lkocman@rcm-dev:comps> locate-rhel7-rpms udisks2 | egrep "lvm2|iscsi"
Client/x86_64/os/Packages/udisks2-iscsi-2.7.3-6.el7.x86_64.rpm
Client/x86_64/os/Packages/udisks2-lvm2-2.7.3-6.el7.x86_64.rpm
ComputeNode/x86_64/os/Packages/udisks2-iscsi-2.7.3-6.el7.x86_64.rpm
ComputeNode/x86_64/os/Packages/udisks2-lvm2-2.7.3-6.el7.x86_64.rpm
Server/ppc64/os/Packages/udisks2-iscsi-2.7.3-6.el7.ppc64.rpm
Server/ppc64/os/Packages/udisks2-lvm2-2.7.3-6.el7.ppc64.rpm
Server/ppc64le/os/Packages/udisks2-iscsi-2.7.3-6.el7.ppc64le.rpm
Server/ppc64le/os/Packages/udisks2-lvm2-2.7.3-6.el7.ppc64le.rpm
Server/s390x/os/Packages/udisks2-iscsi-2.7.3-6.el7.s390x.rpm
Server/s390x/os/Packages/udisks2-lvm2-2.7.3-6.el7.s390x.rpm
Server/x86_64/os/Packages/udisks2-iscsi-2.7.3-6.el7.x86_64.rpm
Server/x86_64/os/Packages/udisks2-lvm2-2.7.3-6.el7.x86_64.rpm
Workstation/x86_64/os/Packages/udisks2-iscsi-2.7.3-6.el7.x86_64.rpm
Workstation/x86_64/os/Packages/udisks2-lvm2-2.7.3-6.el7.x86_64.rpm

Comment 4 Martin Banas 2019-03-22 11:54:41 UTC
This bug has moved to ON_QA without qa_ack. I'm closing as CURRENTRELEASE.


Note You need to log in before you can comment on or make changes to this bug.