Bug 1567744 - Hang or NULL pointer dereference if reading sysfs during VDO start/stop. [rhel-7.5.z]
Summary: Hang or NULL pointer dereference if reading sysfs during VDO start/stop. [rhe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kmod-kvdo
Version: 7.5
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Thomas Jaskiewicz
QA Contact: Jakub Krysl
URL:
Whiteboard:
Depends On: 1559692
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 07:03 UTC by Oneata Mircea Teodor
Modified: 2018-05-14 16:13 UTC (History)
6 users (show)

Fixed In Version: 6.1.0.164
Doc Type: If docs needed, set a value
Doc Text:
When a process was reading Virtual Data Optimizer (VDO) sysfs entries while a VDO volume was starting up or shutting down, the process and the VDO task sometimes became unresponsive or terminated unexpectedly. With this update, the sysfs entries are created and released at the correct time. As a result, the described problem no longer occurs
Clone Of: 1559692
Environment:
Last Closed: 2018-05-14 16:13:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1407 0 None None None 2018-05-14 16:13:39 UTC

Description Oneata Mircea Teodor 2018-04-16 07:03:27 UTC
This bug has been copied from bug #1559692 and has been proposed to be backported to 7.5 z-stream (EUS).

Comment 3 Jakub Krysl 2018-05-03 15:35:29 UTC
Using the reproducer I was not able to get vdo to hang or get any calltrace. Reading from /sys correctly produces either value ('0') or error ('cat: /sys/kvdo/vdo0/statistics/data_blocks_used: No such file or directory'). The start/stop cycle keeps going.
No regressions found as regression testing passed.

Comment 6 errata-xmlrpc 2018-05-14 16:13:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1407


Note You need to log in before you can comment on or make changes to this bug.